Deleted wrong boot menu item, Win7 won't boot

#1
I tried to get EasyBCD to dual-boot my Windows 7 and Xubuntu Linux partitions.

Windows 7 was installed first (OEM install) and Xubuntu was successfully installed afterwards. After that, Xubuntu would not boot, so I used EasyBCD to add a Xubuntu boot option.

This didn't work - when I selected that option, the Windows bootloader complained that "the selected entry could not be loaded because the application is missing or corrupt".

I had accidentally created two Xubuntu entries (EasyBCD does not give any feedback or indication that it is working, so I clicked the relevant button twice. Both entries gave the error, but the Windows 7 entry still worked. I booted into Windows, deleted one of the Xubuntu entries, and upon reboot, had the same problem.

Then I deleted the other Xubuntu entry, leaving only Windows 7. Without rebooting, I added a single Xubuntu option and rebooted. I am certain that I deleted the correct entry, and that at this stage, I had a Windows 7 and a Xubuntu entry in the EasyBCD window.

I rebooted, and was presented with two Xubuntu options, both broken, and no way to get into Windows.

I am currently attempting to download a Windows 7 DVD since I understand it is probably needed to fix the problem. I am also currently burning the automatic factory-state backup DVD to disc in the hope that it will have a similar recovery console available (edit: it doesn't).

Can you tell me how to restore the ability to boot Windows 7?

Edit: The Windows 7 installation CD I downloaded says it is incompatible with the Windows 7 on my machine, so now I need a solution which does not rely on a Windows 7 installation CD. I am competent in Linux, know nothing about the Windows world.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Contact systemdiscs and get them to swap your download for the other version
(x86/x64).