Desktop does not load - please help

#1
My desktop does not load when starting vista home premium. I get a blank screen with the mouse arrow. Clt-atl-delete brings up task manager. I know at least Explorer.exe is not running...there may be other things that are not running. Any thoughts on how to fix this.

Some background: I had a dual boot set up with Xp installed first, then vista on one hd with two partitions. I used easyBCD as the boot manager. Vista was working well, so I decided to remove xp from the dual boot.

Using easybcd, I removed xp from the boot. Then I made the vista partition active. Using gparted, I formatted the xp partition and then extended the vista partition to the newly unallocated space. Everything worked fine.

I restarted with my vista dvd and used the repair function to restore the vista boot manager. Everything seem to go well and the repair function required a restart. I restarted and got a rundll32 - permission not allowed error I believe (didn't write it down). I restarted again.

Windows stalls at preparing your desktop then loads to a blank screen with a mouse arrow. Tried safe mode with the same results. Cl-alt-delete does bring up the task mananger. I noticed explorer.exe was not running.

I run explorer.exe and it starts up a windows desktop with my user account but in a limited mode. Nothing is available - my doc, pict music etc, all empty folders.

Any thoughts on what is going on or how to fix this?

More info: just noticed my drive is now labeled "D." Should it be labeled "C." Computer Management will not load so I cannot check anything there.
 

mqudsi

Mostly Harmless
Staff member
#2
Did you get any warnings about Windows activation?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#3
I dont think Activation has anything to do with this. I think this has more to do with teh extension of the Vista drive. Which has create the problem where at the end he stated that Vista is no longer the D:\ drive but the C:\ drive. That would mess up the loader and also all things within Vista. Like the profile location and everything that is isntalled.

It should be labeled whatever it was when you had Installed Vista. If it was C:\ then yes it should still read C:\ if it read D;\ then it should read D:\. Sadly there is no known fix from what i know when extending the Vista partition like such other than a format and re-isntall. Almost everytime i have come across this issue it came down to a re-install as almost all the info on the Vista drive became corrupt.
 
#4
Thanks for the quick replay.

No, mo warnings about activation - just the rundll32 permission error.

If I try to run easybcd 1.7, I get a .net framework initialization error.

I tried to follow your wiki and forum instructions to do this. The only other things I did were to make my the vista partition active and use easybcd to restore the boot file prior to formatting what gparted saw as my c drive. I reformated c and extended d which had my vista installation. Could this be related to the only drive being labeled as d now?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#5
Well the Vista drive should be active. That is for sure. You can try to restore the bootloader. The instructions are here:

Repairing the Windows Vista Bootloader - NeoSmart Technologies Wiki

I dont think the thing about the D being the only drive causing a issue. It could but i wouldnt think so. But it could be that the partition lables are now wrong. Before Vista was located on teh 2nd partition on the first drive. Now it is located on teh 1st partition on the first drive. That could be where the problem lies.
 

mqudsi

Mostly Harmless
Staff member
#6
You're right - darnatl, you'll want to make sure the Vista partition is the active one before trying anything else.
 
#7
That is my guess. If I start explorer.exe in task manager, it loads my user account but says it is a temp account and everything will be lost on restart. If I got my documents, nothing is there. If I explore my "d" drive user accounts, a quick unreadable message flashes saying something about install then explorer shows all my files. So, it seems everything is there, but windows is not able to correctly load my user account.
 

mqudsi

Mostly Harmless
Staff member
#8
Use Acronis Disk Director to change the drive letter.
 
#9
I'll have to download that. I have acronis true image but not director.

I checked in gparted again. It labels my drive as:

Path: /dev/sda2
Satus: not mounted
File: ntfs
Flags: boot
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#12
That was the XP Drive that got formatted and combined into the Vista drive.
 

mqudsi

Mostly Harmless
Staff member
#14
Does it give you that option?
 
#15
There is a menu to set disk label. It gives you an advanced menu with the default being msdos label there are about 10 other options, none of which are familiar to me. I warns that setting a disk label for /dev/sda could cause you to lose everything on the disk.

Maybe disk director would be the better option for me - more computer illiterate friendly :smile:

Is there a way to get computer management to load. I get an error message saying MMC could not create the snap in - it may not have been installed correctly.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#16
Disk Director lets you pick the letter
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#17
If you cant get your profile to load you wont get computer management to load.
 
#18
Thanks, I'll try disk director tonight and change the drive letter to c and see if that works.

Addendum:

Another problem, windows installer will not let me install disk director. Acronis installation error #1601. Windows installer service could not be accessed. Windows instlaller may not be correctly installed. Is there a work around?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#19
well, there's a bootable iso image for acronis disk director - but you need to install it to make the bootable CD.
 
#20
Okay, I booted with acronis disk director 10. It sees the drive as "c" and since it is the only drive, it does not allow the option of changing the letter.

So, I thought I would boot with my windows dvd and try to repair the start-up again. Windows searched for the system and found it on what it recognizes as my "c" drive.

When I boot into the temporary windows profile, it still shows my drive as "d." Gparted also shows /dev/sda2.

This is obviously a challenging problem. I really do appreciate your help and knowledge.