Destroyed my Vista/Linux Dual Boot with Gparted

#1
I originally had Vista Ult 64 installed, made room for OpenSuse Linux, did the install, then used EasyBCD under Vista to make the system dual boot. Had no problems for many months. Then I foolishly decided that I had too much space on Linux and should move it back to Vista. So I used Gparted, which showed me my big Vista partition and the various Linux partitions. I reduced the extra linux partition which gained me 35G of unallocated space. Then I tried to expand the Vista NTFS parition, but couldn't see an easy way to get back that space. I noticed there was another unallocated space of 5GB, so I expanded into that.
Now, when I reboot the machine, I get to the "Windows Boot Manager" page, which gives me my choices of Vista or OpenSuse. If I choose Vista, it says: Windows failed to start, blah, blah...File: \Windows\System32\winload.exe Status: 0x0000225 application is missing or corrupt. For OpenSuse, it says a similar thing, except for \NST\nst_grub.mbr

Is there any easy way that I can get into my system and edit the appropriate files (boot.ini) or run EasyBCD from a boot disk and get my system back? I'm dead in the water...

Thanks,
Michael
 
#3
Mahmoud,
Thanks for your prompt reply. I am creating the Vista recovery disk now and will report back.
-Michael

Addendum:

Well, I'm afraid I made things worse before I contacted you. I used one of my boot DVDs and chose Acronis OS Selector...now I don't know how to get past that. It will let me boot to my OpenSuse partition, but doesn't show Vista. Now I need to figure out how to uninstall this thing so that I can use the Vista recovery disk...

Addendum:

Ok, Acronis has been uninstalled and I ran the Vista recovery disk. It went thru the startup repair process, but now my machine boots directly to OpenSuse with no option to go to Vista.

Addendum:

When I try to fix things via the command prompt, bootrec.exe /fixmbr seems to work fine, but when I cannot get bootsect.exe to work. I found the program on my Vista C: drive in the EasyBCD bin directory, but copied it to c:\ to make things easy. When I issue the following:
C:\bootsect.exe /nt60 all /force

All I get is: "The system cannot execute the specified program. Even if I go to C:\ and
run bootsect.exe, I get the same error. Stuck...


Addendum:

Ok, I managed to fix it. Never could get the bootsect file to work, but asked the startup repair to run several times until it managed to repair itself. Now I get the boot manager prompt for both OSs, even though Vista says (recovered), at least it boots!
Thanks for listening....
 
Last edited:

JustinW

Super Moderator
Staff member
#4
You can change the description for Vista's entry to remove the (Recovered) part with EasyBCD. Why MS had to be so lame to put that in there at the end of a recovery is beyond me...
 

Terry60

Knows where his towel is.
Staff member
#5
I think your problem with bootsect was an assumption that it was on C:
You put it on C:\ in Vista when Vista was C:\, but when you boot the recovery disk and execute the recovery console it will be C: and see your Vista partition as some other letter. Trying dir D:\ etc. till you locate the Vista files, will show what letter to use.
Academic anyhow. I prefer to let the auto-repair do the hard work for me anyway.
 
#6
In any case, I was able to get things back to normal. Hopefully won't have to go through this again, but thanks to all who are part of this forum. Good to know there is a knowledgeable team behind a good product.
-MXC
 
#7
Guys, I still am not able to get my OpenSuse partition to boot from the windows boot manager. It is still telling me that \NST\nst_grub.mbr is missing or corrupt. I tried looking for some way to restore this through EasyBCD, but it appears to only address Vista boot problems. Any guidance on how to restore my dual boot?
Thanks

Addendum:

Ok, I just deleted the existing entry and created a new one, and that seemed to fix it.
 
Last edited: