dual boot, auto-mount win 7 HD in ubuntu

#1
I have a dual-boot system, windows 7 and ubuntu 10.10. I created a small partition & formatted it as fat32, then placed my firefox and thunderbird profiles on that partition. Then I created new profiles in firefox and t-bird in ubuntu so that I could share those apps between the two OSs.

Everything is working great except for one tiny inconvenience. I have to mount the fat32 drive in ubuntu before I could use firefox or t-bird. OK so I thought "this won't be hard .. I'll just set it up to auto-mount on startup" ... well .. I've tried manually editing the /etc/fstab file and also tried using the mount manager .. both of those successfully mount the partition, but when I auto-mount it, firefox and t-bird no longer work. I've tried re-doing the profiles, but still no workee ..

Anyone know how to fix this? I've searched the internet and cannot find any info related to this. I've read dozens of google links on how to share these apps between OSs, but none of them address the 'auto-mount problem' ...

thanks

george c
 

mqudsi

Mostly Harmless
Staff member
#2
Hi George,

You'd probably be best off asking this on the Ubuntu support forums at Ubuntu Forums
 
#3
problem solved

thank you for the response, and that's a very good point. I actually did find a link to a solved issue on their forum that solved my problem just 20 minutes ago :smile:

george c
 

JustinW

Super Moderator
Staff member
#4
I'm curious. Was it that the partition was mounted read only? Thats the only reason I can think of that your programs would crash on you with the partition mounted.
 

mqudsi

Mostly Harmless
Staff member
#5
Nice catch, Justin! Didn't even think of that....
 
#6
I'm curious. Was it that the partition was mounted read only? Thats the only reason I can think of that your programs would crash on you with the partition mounted.
apparently yes .. I had to have permission to write to it I'm guessing. I'm a novice (actually, pretty much of a luddite) at these things, but in the fstab file where I put the mount info, I had to add myself as user. I'm in windows right now, but if you want, I'll boot back into ubuntu and cut & paste the exact change I made in order to make it work, or you can check out the link I posted..

george c
 

mqudsi

Mostly Harmless
Staff member
#7
Hey, if you're geek enough to mess around with Linux (let alone fstab!!!!), you're not allowed to call yourself a luddite :smile:
 

JustinW

Super Moderator
Staff member
#8
Sure, I've tried to setup fstab myself before as well and I can never seem to get the options right. I'm sure someone else browsing this thread with the exact same issue would appreciate if the solution be posted.
 
#9
here's the change to fstab

ok here is what I changed in fstab:

OLD (no workee):
UUID=9618-FF84 /media/WINLIN vfat defaults 0 0


NEW (works great):
UUID=9618-FF84 /media/WINLIN vfat defaults,uid=george,gid=george,dmask=0027,fmask=0137 0 0

I don't understand why I had to do this, but if I tried to auto-mount using 'mount manager', it didn't work either, and I put 'anyone' in place of the default 'administrator' in the 'who can mount this partition' spot.

I don't know what dmask and fmask are .. I'll look at that later .. gotta get back to work now :smile: