Dual boot, dual hdd pain!

#1
Hello,
I am trying to dual boot Vista and Ubuntu 9.10. My setup is:
sda -> Vista
sdb -> Ubuntu (Usb hdd)

My original plan was to just select between the two in the BIOS, but that didn't work, so the next logical step was to use easybcd.
I have 3 options from easybcd:
1. Add a linux/grub2 entry.
2. Add a neogrub entry and chainload.
3. Use PLoP.

Results:
1. Hangs a "Starting cmain()..." and corrupts my Ubuntu partition :rage:(maybe me shutting off the computer after it freezes is the causes the corruption.)
2. The same thing as this post happens, from there I can then start grub2 by typing
Code:
root=(hd1,0)
kernel /boot/grub/core.img
boot
3. Works.

Problem with the current state of options 2 and 3 is that they're slow and require input. Option 1 makes me have to reinstall Ubuntu. This setup worked fine with ubuntu 8.04 with legacy grub on non ext4.

Any help would be appreciated! I really don't want to replace the windows loader for grub.
 

mqudsi

Mostly Harmless
Staff member
#2
OK,

2 it is.

EasyBCD | Add/Remove | Configure NeoGrub

in there, write what you normally type at the GRUB prompt to chainload grub2 (what you posted above).

save, exit, and reboot.
 
#3
Yea, I had tried that. No matter what my menu.lst is, it always goes to that screen.
Currently is is:
Code:
title Ubuntu
root    (hd1,0)
kernel        /boot/grub/core.img
boot
Wast the linux-> grub2 option suppose to work properly with my setup? (2 seperate drives)
 

mqudsi

Mostly Harmless
Staff member
#4
Looks like it's failing to load the menu.lst....

The GRUB2 option was supposed to work, but it looks like there is something with your configuration that is preventing the menu file from being found..

Do you have SATA or IDE disks? Any RAID set up?
 
#5
They are both sata disks, one internal, the other is in a usb enclosure.

The menu.lst would be on the internal drive (ntfs formated.)

There is no raid setup.
 
#6
Where did you install Grub when you installed Ubuntu?
 
#7
I first tried installing it at hd1,0 and afterwards at hd1.

Update: I feel stupid for not trying this earlier, but pressing ESC makes the menu appear.

I'm now getting corrupted partition messages, which I'll try to deal with on my own.

Is 'hiddenmenu' set internally or something? I want to set it up so that it directly goes to the other loader (timeout=0.)
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#8
No, hiddenmenu is from the Ubuntu menu.lst found at /boot/grub/menu.lst

Good luck with the corruption issues.
 
#9
SOLVED!

I figured out the cause of the problem: Whenever I was trying to boot from the usb Hdd, if it hadn't spun up, then it would cause EVERY attempt to boot from it to fail.

I realised that manually resetting the hard drive would cause it to spin up, which now allows me to boot consistently. This works for me since I already have to manually select to boot from the drive.

I don't know if it's just my specific hardware configuration that is to blame, or what.

It may be an idea to create a setting for Neogrub / neo linux to change the how it searches for grub2 and/or how long before it times out.

The title of the thread can now be changed to something more fitting like: " [SOLVED] External HDD booting problems."

Anyways,
Thank you for the assistance!
 

mqudsi

Mostly Harmless
Staff member
#10
Awesome. So I guess EasyBCD works out of the box w/ your configuration as far as the software is concerned, but the hardware is the issue?

My motherboard will wait for all USB devices to be detected and powered-up before it passes the BIOS POST procedure; so when it reaches the bootloader everything will be cool.

Check if your BIOS has a feature to wait on HD detection.