Dual Boot No Longer works for Vista/XP

#1
Summary of problem: I was able to successully dual boot Vista and XP on my laptop, but am no longer able to see the option to boot XP.
I initially allocated 3 partitions on a Dell Latitude laptop with a new 250 GB harddrive. The smallest partition was used for Dell software. The middle sized partition was allocated for XP. The largest partition was for Vista, and took all the free space left on the drive.
I first installed XP and all the updates that Microsoft provides. That worked great! Then I installed Vista and all the updates from Microsoft. That worked great, and dual boot worked fine. Then something happened (if I knew, I'd tell you). I was able to boot Vista, but not "see" XP from Boot Manager.
The I installed easyBCD v 2.0.0 hoping to resolve the problem (dual boot doesn't work). I tried to "add" XP, letting EasyBCD find XP, but none were found. I tried to point to the volume it's on, and it could find an operating system.
I tried both Vista and XP recovery consoles. Neither worked.
So, here's "View Settings" output from the EasyBCD on the laptop:
*****************************************
There is one entry in the Windows bootloader.
Default: Microsoft Windows 7
Timeout: 10 seconds
EasyBCD Boot Device: D:\
Entry #1
Name: Microsoft Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
*****************************************
I just don't know what to do, but I'd like to get dual boot to work without having to reinstall either Vista or XP. Thanks, George.
 

Terry60

Knows where his towel is.
Staff member
#2
Can you see XP from Vista Disk Management and Explorer ?
What's the name of the folder containing XP ?
Is it one of "Windows" "WinNT" or WinXP" ?
If it's not one of those, EasyBCD can't guess what you might have called it.
 

Terry60

Knows where his towel is.
Staff member
#4
Try the latest Beta and add the XP entry again (auto)
If that doesn't work, post a screenshot of your Disk Management.
 
#5
Unintalled 2.0.0; download and installed 2.0.2. Results are the same: no valid NT found when add XP. Screen shot of Disk Management uploaded as DiskMgmtApr14.gif (not sure if upload was successful).
 

Attachments

mqudsi

Mostly Harmless
Staff member
#6
EasyBCD | Useful Utilities | Power Console

Please post the output of

bootgrabber.exe /tlist

and

bootgrabber.exe /bootcfg
 

Terry60

Knows where his towel is.
Staff member
#7
The latest Beta is 2.1 build 138
 

mqudsi

Mostly Harmless
Staff member
#9
It doesn't look like you're using EasyBCD 2.1 beta build 138.
 

mqudsi

Mostly Harmless
Staff member
#11
EasyBCD | Useful Utilities | Power Console

convert D: /fs:ntfs

Then try again, please.
 

mqudsi

Mostly Harmless
Staff member
#13
You're most welcome. Glad we could help :smile: