Dual boot Openuse and Win 7

#1
Hello,
My question concerns dual booting with Opensuse. I’ve read the wiki and I think I’m on the right track but if some could read my config posted below and please let me know if it’s correct. I’m disabled so I don’t want to reboot into a mess. Firstly I had installed Suse a week ago before I installed EasyBCD and iReboot today. When I installed Suse I installed it’s bootloader to the root partition, however, it was the Suse loader that was dominant so I chainloaded Windows 7 with it. And that’s how booted into Windows where I am now.


I then used EasyBCD to restore the BCD backup and subsequently used it again to install the Windows 7 bootloader to the MBR. I’m hoping this is correct but I have a nagging suspicion that the word grub should be in the Linux boot config. The partition I chose is indeed the Suse root partition.





There are a total of 2 entries listed in the bootloader.


Default: Microsoft Windows 7
Timeout: 10 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Microsoft Windows 7
BCD ID: {default}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: NeoSmart Linux
BCD ID: {e5a5222e-eba5-11df-ac2f-83229af89c06}
Drive: C:\
Bootloader Path: \NST\nst_linux-0E79406678845F2948F4EE168005C489.mbr
 

mqudsi

Mostly Harmless
Staff member
#2
Have you tried ticking the checkbox that says "GRUB is not installed to the MBR?"
 
#3
I did but it just boots back to the Windows menu. I managed to get it using Neogrub but it too will boot to a menu but with my Openuse as selection in the grub for dos. Is there a way to get it to bypass that menu and boot straight to Linux? Thanks.

Addendum:

Wow! Today pressing enter shows an error as if no grub is present. It did work last night. I don't know what went wrong. This is still the Neogrub. Using the regular grub installation and putting a check in the box still sends me back to the EasyBCD Windows menu.

Addendum:

Still trying to configure Neogrub. Here is the config and I am unable to boot into Linux without error 15. It can't find grub. I went into Suse and made sure sda 7 is the root and also disabled the boot from extended partition option.

I don't know what I'm doing wrong. I need some help please. Thanks.

title OpenSUSE 11.3
find --set-root /boot/vmlinuz-2.6.34.-12
kernel /boot/vmlinuz-2.6.34.-12-desktop pro root=/dev/sda7
initrd /boot/initrd-2.6.34.-12-desktop
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
error 15 generally means you're looking in the wrong place. Did you select the Linux partition in the dropdown menu where you installed grub ?
 
#5
Yes thanks. I have two partitions roughly the same size and one is for another Linux not yet installed. EasyBCD shows them as the same size since it rounds them off so I simply chose the wrong one. The order being different is what my mistake was. Live and learn -thanks again.
 
#6
After finding the correct partition for the previous installation of Opensuse I thought I was ready to use the free partition that I had previously chosen in error, to install PC Linux and so I did. The problem is I cannot find it at all even when I try to reinstall the grub from the terminal in the live CD. The command find/boot/grub/stage2 produces error 27 unrecognized command.

I tried reinstalling and putting the grub in the root partition in this case sda/8. That produced error 12 something about a device problem so I reinstalled it the normal way but I can't find it. Opensuse is installed on the previous partition sda/7. I'm finding one very odd thing in all of this is that when I change between partition 7 and 8 using Easy BCD (using the drop down menu) it manages to boot Opensuse each time as if it was installed in both partitions. There is no sign of PC Linux anywhere and I've installed it three times now to no avail. I have no idea what to do can someone please help? Thank you.
 
Last edited: