Dual Boot Trouble

#1
I'm hoping someone can help me here.

I had installed XP on a 250GB Drive.
I then put another install of XP on a 1TB drive and got them dual booting just fine.
I then partitioned the 1TB drive and added Win7 to the new partition.

If I reboot with the Win7 DVD in, it will give me the option to start Win7 or XP. If I select XP, it will then go on to give me the option of starting one of the two installs of XP.

If I reboot without anything in the drive, it just skips straight to the option of booting between the two XP installs. It doesn't allow me to choose Win7.


So far I've tried..
- The above.
- Installing XP on 1 partition and then Win7 on the other partition of the same drive.
- Installing Win7 and then XP on the other partition of the same drive.

No matter what I do, if I don't have the Win7 DVD in the drive, it will only boot XP. Can anyone tell me what I'm doing wrong?
 
#2
Hi Tripnolgoist. Welcome to NST.
Go into your BIOS (by pressing F2 or similar at startup, while still at the manufacturer's page) and put your Win 7 drive first in the boot sequence, instead of XP's. If you still are not able to boot into Win 7 after that (due to XP being installed that last time, after Win 7) then boot from your Win 7 DVD, and run Startup Repair with the Win 7 drive still the first HDD in the boot sequence. That should put Win 7's boot back in charge, and you should be able to boot into Win 7. And then if you don't get to a menu in which you can select to boot into either Win 7 or one of your XPs, then simply use EasyBCD from Win 7 to add 2 new entries to your Win 7 boot menu to boot XP. Do this though with [thread=642]the latest Beta build of EasyBCD[/thread] as it will give you the option of autoconfiguring boot.ini, so you wont have to manually. Now whichever partition is "system" on WIn 7's drive (you can check Disk Management from Win 7 when you're in), your XP boot files (boot.ini, ntldr, and ntdetect.com) need to be on that partition. So copy them over from XP's partition root, if your XP partition is not the one that is "system". And then use 2.0's autoconfigure feature to automatically configure boot.ini.

Cheers,

Jake
 
#4
Glad you got it working :smile: Let us know if you have any more trouble.

Cheers,

Jake