Dual Boot Two Hard Drives Corrupted - Help Please

#1
Hi;

I have a dual hard drive dual boot Windows 7 / XP setup, with XP on one HDD and 7 on the other.
The boots to Windows 7 by default with an option to switch to XP if required
A short while ago I disconnected both HDDs to test a damaged HDD however when I reconnected my HDDs my PC booted straight into XP bypassing the boot option. The windows 7 HDD is visible in explorer.

I have followed the troubleshooting to try and add / repair the bootloader but all I have managed to do know is corrupt my PC further and now the PC hangs at the Windows XP Splash Screen!!!!

What's the best way to get this PC back up and running and get the dual boot working again?

Thanks
 

Terry60

Knows where his towel is.
Staff member
#2
When you disconnect a HDD which is at the top of the BIOS bot sequence and reboot, when you reconnect the original HDD it will not go back to the top of the boot sequence.
You must go into the BIOS setup utility
How to access/enter Motherboard BIOS
and put your W7 HDD back on top of the HDD list.
(or if it's a Dell PC, you'll need to swap cables to make the W7 disk on the 1st SATA channel)
 
#3
Hi, the motherboard is an Abit AN-M2HD an according to my research uses the Phoenix Award BIOS. In the BIOS you can select boot priority but not down to specific HDD it only lets you select by type i.e 1st HDD, 2nd CD ROM etc see screen shots at the following link. http://www.overclockersclub.com/reviews/abit_m2hd/3.htm

Is there still a way to change the HDD boot order?

The good news is i rebooted the PC and it did successfully boot into XP.

One HDD is SATA and the other is IDE.

Should I identify the XP HDD and disconnect it and see if I can boot into Windows 7 and try the BCD repair steps from within Windows 7
 

Terry60

Knows where his towel is.
Staff member
#4
In the Phoenix BIOS you can drill down another level.
The top level specifies the order of device types e.g. Removable / CD ROM / HDD
Then within Removable, Floppy etc
within CD ROM the order of your optical drives
and within HDD, the order of your HDDs
 
#5
Couldn't get past the HDD option to choose an HDD but when i booted the PC i hit ESC which takes you into boot options and with HDD selected as the boot device if you hit return it then showed me both my HDDs and so I could choose my Windows 7 HDD. The PC Booted into the OS Choice Screen and I am now in Windows 7. (Actually I am typing this from my Mac).
 

Terry60

Knows where his towel is.
Staff member
#6
That's just a temporary override. You still need to change the BIOS, or it will go back to booting from the other HDD by default unless you intend to override it every time in future.
Play around with the BIOS setup some more. Select the HDD option in Boot Device Priority and hit Enter.
 
Last edited: