Dual-boot Vista and Ubuntu Problems

#1
Ok....so....I have been at this for a while....and, I have reformatted my computer a very large number of times.....

I have an HP dv9230us laptop with two 100 GB HDs....I have vista installed on hd0 and ubuntu installed on hd1.....I have used the live cd to write grub to hd1 and i have added entries in neogrub through easybcd for both linux boot with grub and without

in addition...i created some entries in neogrub that would try to find the /boot/grub/stage1 and all of that.....it always says the file cannot be found

also, i tried to add some with a "root (h1,0)" command at the beginning....which...it finds the partition....but it says something like.."the partition is ntfs....(hex value)"....and i very clearly know that ubuntu in an ext3 filesystem is at that partition number.....or at least...easybcd seams to thing so too....

anyone have any solutions?

thanks in advance

Addendum:

also.....the last time i installed ubuntu....i changed advance to install grub to (hd1,0)
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
If "find /boot/grub/stage1" or "find /boot/grub/menu.lst" returns file not found, it means that you either have a corrupt partition or GRUB was not correctly installed....
 
#3
Het man, thanks!....I understand that there is a problem that it cannot find either of those files....could there be a reason for a corrupted grub?.....also, why would setting the root to that partition return an ntfs statement?
 

mqudsi

Mostly Harmless
Staff member
#4
Probably because the numbers are wrong...
 
#5
EasyBCD states:

Drive 0
Partition 0(HPFS/NTFS - 93 GB)
Drive 1
Partition 0(Linux native - 23 GB)
Drive 2
Partition 0(HPFS/NTFS - 233 GB)
Drive 3
Partition 0(HPFS/NTFS - 466 GB)

The first two are my laptop's internal HDs....the second two are externals....is the number not (hd1,0)?
 

mqudsi

Mostly Harmless
Staff member
#6
It *should* be, but please try different combinations, just in case.
Perhaps (hd0,0) will work.
 
#7
Thanks for the responses man!

yeah, i tried all kinds of different combinations......you know how neogrub has just the command line?

i tried
root (hdx,y) from 0<=x<=3 and 0<=y<=3

and none of them returned a statement about the partition being ext3?


Addendum:


could the fact that my HDs are scsi be problem?


Addendum:


in addition lol....i looked through some posts about hd configuration....i went into the windows disk management....my vista drive says

Location 0 (Channel 0, Target 0, Lun 0)

The drive with linux says

Location 0 (Channel 2, Target 0, Lun 0)

anything there that can shed some light?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#8
I don't think NeoGrub supports SCSI drives.
 
#9
do you happen to know any way to boot linux when an scsi drive is the case?

Addendum:

and it's weird....windows says it is ATA.....but when i install linux.....it says it is installing to scsi?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#10