Dual Boot Vista and XP. XP is not drive letter C

#1
I searched the forums a good bit before asking. I know on other forums I'm a part of we get angry when people don't search so I tried.

My problem is Vista is on drive C. XP is on drive F. When using EasyBCD I can't choose anything other than drive C for XP. Is there a fix for this? Sorry if it's something dumb I missed.
 

Terry60

Knows where his towel is.
Staff member
#2
Hi Erifnomi, welcome to NST.
That option is "greyed" to stop you from changing it.
The entry points to the XP boot files, and they, in turn, point to the XP OS.
Have a read of the wiki, and copy the three XP boot files into your Vista root.
Then edit C:\boot.ini to point to the XP partition.
(remember all the files are hidden so unhide all system and hidden files and known filetypes in folder options if you can't find them)
 
#3
How are you setting up the dual boot between the two versions of Windows? On one single hard drive or across two? Installing XP after Vista on the same drive or even on a second will see a drive letter other then C assigned to it even when you boot into XP itself. Vista being the first on takes C right off.

Once you uncheck the "hide all protected systems" option in the menu bar>tools>folder options>view tab you simply open two explorer window while booted in Vista to see the NTDETECT.com, ntldr, and boot.ini files copied over from the root of the XP primary to Vista's root. Then you right click on the boot.ini file itself to uncheck the "read only" box followed by clicking the apply button where you can then use NotePad to make the necessary corrections.
 
#4
Thanks for replying so quick. I can't find those files. I've made it show hidden files and I've looked myself and searched. I'm using one physical drive with three partions, one for Vista, one for XP and the third has the factory backup.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#5
You need to show the system protected files as well. Use the same method to show the hidden files but scroll down a couple of lines. There you will see the option:

Hide System Protected Files (Recommended)

Uncheck that box. Then you will see the files mentioned. Normally you dont need to go this far to see files but these files are important to the system that is why they are super hidden. :wink:

Just hide them again after you copy them over.
 

Terry60

Knows where his towel is.
Staff member
#6
I mentioned three categories to unhide (3 boxes to tick/untick).
System files, hidden files, and extensions for known filetypes
 
#7
Once the files are visible and copied onto the Vista primary you still will need to right click on the copy of the boot.ini file before you can save and overwrite the original with the needed changes. That is set default by Windows to "read only" on the properties screen being a protected system file.

Once you follow that by simply double clicking on the file itself after or opening it up manually with NotePad seeing the partition values changed you need to select "all file" when going to use the "save as" option. You don't want the corrected version saved as a text file seeing the txt file extension but allow it to overwrite the copy made.
 
#8
Maybe I'm doing this wrong. Are these files I'm looking for in Vista's partion C or XP's partion. I can find these files on Vista but I thought I needed the ones from XP.
 

Terry60

Knows where his towel is.
Staff member
#9
If they're already there, you don't need to do anything.
You also don't need to change the "greyed" option in your 1st post. It's pointing to the place where the boot files are located.
If you can't boot XP still, check the symptoms in the wiki troubleshooter. That will tell you the fix for any problem you might see.


Addendum:


The files need to be in whichever partition is marked "system" "active" in disk management. (that's not necessarily Vista)
 
Last edited:
#10
The boot files needed will be at the root of the XP primary. You can copy those over while being booted up in VIsta or while in XP if the Vista primary isn't hidden from XP.

Once those are copied onto the Vista primary you simply make the correction needed in the boot.ini file and proceed to add the new entry for XP into the Vista BCD with EasyBCD. If you run into an "invalid boot.ini" message when going to select XP from the boot menu you entered the wrong partition number in the boot.ini file and simply change it to point to the one XP is on.

The wiki Terry60 posted a link for there covers all that plus other types of errors that can come up if something wasn't done correctly. Believe it or not you'll likely have a few occasions where that will be still be needed.
 
#11
Wow I'm very sorry. I could have avoided all this had I just tried. The files were already on the Vista partition and all I had to do was use Easy BCD to add XP to the list. I guess because this is a new, very nice computer I was being more careful that I normally would. Thanks for putting up with me. Great program BTW.
 

Terry60

Knows where his towel is.
Staff member
#12
No problem. Glad it's all OK
 
#13
You can also thank Computer Guru for the excellent work on the programming for the EasyBCD tool from the start since Vista's release. It's made a difference for a larger number of people then you realize already.
 
#14
Yes Thanks everyone who helped with that program. Easy BCD is a must have program for me, joining Gpart Live CD (even though you can easily partition with Vista)