Dual boot: Vista / Frugal Puppy Linux 4.12

0cean

New Member
#1
I installed puppy linux 4.12 in frugal mode on a logical ext3 partition. Grub is installed in /boot/grub on this partition (/dev/sda8).

I tried to add puppy through 'Add/Remove Entries' > Linux Tab and got the following error:
"Cannot load from harddisk.
Insert Systemdisk and press any key."

Then I tried to use NeoGrub. Here's my menu.lst for that:

title Puppy Linux 412 frugal
rootnoverify (hd0,7)
kernel /puppy412/vmlinuz pmedia=atahd psubdir=puppy412 nosmp
initrd /puppy412/initrd.gz

The error is: "Error 2: Bad file or directory type"

I am sure that the directory and partition are specified correctly in this menu.lst. vmlinuz is in the specified dir and so is initrd.

To try something else I put a text file called test into my /dev/sda8 root directory.
Then I hit 'c' at the NeoGrub menu to enter the CLI.
First I typed: geometry (hd0, and hit ENTER. The partitions were shown like gparted would show them - correctly.
Now I typed: cat (hd0,7) /test
I got the following error:
"Error 1: Filename must be either an absolute pathname or blocklist"
Feels like NeoGrub sees the partition but isn't able to read it somehow. Any ideas?

Was anyone able yet to use EBCD to boot into a frugal puppy install?
What else can I try?
 
Last edited:

JustinW

Super Moderator
Staff member
#2
Hi Ocean, welcome to NST

(hd0,7) appears to be the wrong location. If pupply linux is another disk you'll need to replace 0 with other combinations. Otherwise, keep playing around with replacing 7 to see if you can find the correct location.

While others here have had success stories with ext3 using neogrub, I would try ext2 if you continue to have problems to see if that fixes it.
 
#3
I was able to solve my problem. The reason why EBCD didn't work was that my puppy partition had an inode size of 256. I reformatted it (again to ext3) with puppy's gparted to make the inode size 128. Now after re-installing puppy in frugal mode EBCD worked like a charm. Maybe this info will have some value for others.
 

mqudsi

Mostly Harmless
Staff member
#5
Thanks for your post, 0cean.

EasyBCD 2.0 supports inode sizes of 256.