dual-boot vista/linux: set linux as default and 0 delay: can't boot windows

btbt

New Member
#1
Hi,

I have a dual-boot laptop with windows vista and linux installed.
I did not change the MBR and installed EasyBCD, and set the defaults as "boot on linux, with 0 delay"
EasyBCD automatically starts my linux, with grub offering the different boot options, including windows.
But if I select windows, it starts back on EasyBCD, sending me back on my linux grub.

Do I have a way to start windows & reconfigure EasyBCD (ideally without any Windows reinstall nor bootloader scratch) ?

Thanks for your help.
Bruno
 

Terry60

Knows where his towel is.
Staff member
#2
You've created an infinite loop by telling Vista to always boot Linux without an opportunity for any other choice.
Try getting into Windows by booting the Vista DVD, (but don't respond to "press any key") and see if that gets you past the block you've set up.
If you get in, then use EasyBCD either to make Linux default, or to remove the menu choice, but not both together.
If that doesn't get you into Vista directly
"press any key"
boot from the CD
repair your computer
command prompt
issue a bcdedit command to change the timeout back to a positive value
 
Last edited:

btbt

New Member
#3
The only DVD I have is a recovery DVD which I generated with my pre-installed Windows.
It only offers to totally erase my C (Windows) drive & reinstall Windows.
There is no repair option offered.

What are my other options ?
 

Terry60

Knows where his towel is.
Staff member
#4

Terry60

Knows where his towel is.
Staff member
#6
No problem.