Dual boot VISTA - LINUX

#1
I have been running Fedora and Windows (XP and VISTA) in a dual boot mode for several years. First I used Boot Magic, and then more recently Acronis OSS. I decided to try easyBCD to see if it would work better than Acronis.

I followed the instructions to add a Linux bootloader entry. EasyBCD found the Fedora /boot partition (which contains GRUB). However, the overview of entries in the VISTA bootloader says that /boot is located on "Drive: U:\". Since both Vista and Fedora are located on the C drive, I don't understand this. Windows sees /boot as the fifth partition on the C drive, and Linux identifies it as sda3. (There are three logical partitions between Vista and /boot which are enclosed by an extended partition.)

The system boots directly into Vista without providing an opportunity to boot Fedora.

Any help would be appreciated.
 

JustinW

Super Moderator
Staff member
#2
Hi dbaral, welcome to NST.

Your setup does sound a little wierd to me, but lets first suppose its the basics. Make sure that the entry for Fedora is actually saved when you close EasyBCD and that your timeout is set to 5 or more seconds to give you time to cycle through boot entries.

If that fails to work, try repairing the Vista bootloader again using startup repair. It may take a few tries at it to get it to work since some users have experienced success by using startup repair more then once.

Then you'll need to assure that the bootmenu is set to display if it is still not showing. Open an elevated command prompt and issue: bcdedit /set {bootmgr} displaybootmenu yes.

Post back if you still have any questions or problems. I'm sure one of us around here can help.
 

Terry60

Knows where his towel is.
Staff member
#3
Don't quite understand your explanation, Windows assigns letters (C:\ etc) to partitions not whole drives. Can you post a screenshot of Vista's disk management display, and paste a copy of the detailed mode output from EasyBCDs "view settings" so we can see what's going on.
 
#4
Response

Many thanks to the two respondents: they were prompt and helpful.

First, some clarification about the hard drive. I have four Windows partitions (C,E,F,G). C houses VISTA and obviously is primary. E,F, and G are logical partitions, inside an extended primary partition. There are two Linux partitions: sda3, the /boot partition, primary and containing GRUB. The second Linux partition (sda4), also primary, is a LVM which contains the /boot and SWAP files. The LINUX partitions are at the end of a 500 GB Sata drive. Acronis OSS is able to boot both VISTA and LINUX, but it has the annoying habit of shutting down every two or three days.

In response to the previous replies, I have:

1. Zapped the MBR twice, in part to insure that there is nothing remaining from Acronis OSS.
2. Deleted and resaved the Fedora entry and upped the timeout to 10 sec.
3. Activated the bootmenu display. The display shows only VISTA as an option.

Here are two screen shots:

-------------------------------------

There are a total of 2 entries listed in the Vista Bootloader.
Bootloader Timeout: 10 seconds.
Default OS: Windows Vista (TM) Home Premium (recovered)

Entry #1

Name: Windows Vista (TM) Home Premium (recovered)
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #2

Name: Fedora
BCD ID: {ab874146-51db-11dd-9def-b6bcfe3e93ef}
Drive: U:\
Bootloader Path: \NST\nst_grub.mbr

--------------------------------------------

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
default {ab874143-51db-11dd-9def-b6bcfe3e93ef}
displayorder {ab874143-51db-11dd-9def-b6bcfe3e93ef}
{ab874146-51db-11dd-9def-b6bcfe3e93ef}
timeout 10

Windows Boot Loader
-------------------
identifier {ab874143-51db-11dd-9def-b6bcfe3e93ef}
device partition=C:
path \Windows\system32\winload.exe
description Windows Vista (TM) Home Premium (recovered)
osdevice partition=C:
systemroot \Windows
resumeobject {394f20c6-5e5c-11dd-8616-806e6f6e6963}

Real-mode Boot Sector
---------------------
identifier {ab874146-51db-11dd-9def-b6bcfe3e93ef}
path \NST\nst_grub.mbr
description Fedora

------------------------------

Again my thanks to all.
 

Terry60

Knows where his towel is.
Staff member
#5
Can you post the disk management screenshot (use Vista clipping tool to save the display, click "go advanced" below the quick reply box, click on the paperclip and upload the saved image as an attachment), so we can see all the partition status flags.
 

JustinW

Super Moderator
Staff member
#6
Alright, two things that could be causing it to go bad:

1) Restoring the MBR to assure you got rid of Acronis OSS was good, but the entry you have for Fedora in Vista's BCD store is bad. It needs to be readded using EasyBCD and checking GRUB is not installed. Don't bother to do anything else like install NeoGrub ahead of time, It well be installed under the correct configuration automatically when you add the entry for Fedora. Keep in mind however that if Fedora is not the first linux install on the disk, it well boot the other LInux or instance's GRUB and use that menu.lst. In that case, you'll need to copy your boot entries from one menu.lst to another if you still cannot boot after readding the entry in EasyBCD.

2) From looking at the description of your hard drive's layout, I'm bit confused as to why the boot drive to the Fedora entry is U:. You don't seem to have any U: partitions and even if you did, EasyBCD is designed to place \NST\nst_grub.mbr on your active partition. Your active partition is where your Vista's boot files are located and where the computer goes to startup. Since i'm assuming the first OS you installed was Vista on C:, that is what should be listed as the boot drive under Fedora's entry.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#7
Go to the change settings page, and set the partition for the Fedora entry to C: instead of U:
 

mqudsi

Mostly Harmless
Staff member
#9
Great, glad that worked out.

When EasyBCD reports "U:" for an entry, that means that it's referencing a partition that has been modified, is not recognized, or no longer exists.

You just needed to point EasyBCD to the correct boot partition once more.