Dual-boot Vista + Ubuntu - tried everything - recurring issue

#1
I have a Toshiba Satellite with Vista and Ubuntu installed. On booting, all I get is a flashing cursor on a black screen. The boot loader does not appear and I have been using the Grub Super Disk to get into it.

After first installing Ubuntu I was using GRUB as a boot loader but this resuted in various problems so I switched back to the Vista boot loader and, after more problems, eventually also discovered EasyBCD. I've tried all the EasyBCD recovery options and they each fixed the problems for a few days/reboots, but after 3-4 reboots the flashing cursor with no boot loader would be back.

I don't understand how things could be "resetting" like this and why it's not consistent (i.e. it works for a while then reverts).

Is there anything else to try? I'm getting desperate and don't want to reinstall everything.
 
#2
I was seeing problems here trying to get ubuntu added along with an XP/Vista dual boot until seeing Grub become the first with the Vista loader as second. One item used at one time was a unbuntu boot manager seen on a 3 1/2" floppy that would load anything simply by selecting a partition or drive or both in order to see the OS installed there load right up.

With the EasyBCD tool that uses the NeoGrub loader there for any Linux distros you want to add on. The main problem of course is that is for the Vista boot loader while a tool for editing the /boot/menu.lst Linux loader would still be needed.

With the newer laptops and desktops now seen the automatic recovery process is the likely reasong for seeing the boot loader corrections being made. To see Windows fully restored on new desktops as well as portables and eliminate the added cost of recovery disks the full factory restore is now simply a specified combination of key pressed at startup. An automatic boot loader restoration tool seems to be working there!
 
#3
I'm not sure I understand you.

Is there a solution to this or should I be asking elsewhere do you think (like the Toshiba Satellite forums)?
 
#4
I would hang on a bit here while still having a look anyways. This is simply since any forum there won't be able to help with EasyBCD to start with.

The live cd install seen here was a first with the EasyBCD as well as HnS beta tool involved for a stretch of the already custom dual boot of the two MS versions. As far as the possible reset of the BCD by some preinstalled restoration process that is a possible explaination for this. It would be something similar to a firewall safe guarding the boot sector and restoring the mbr if found.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#5
#6
As mentioned in the original post, I have already tried all the EasyBCD recovery options mentioned in the wiki article. It works for a few days/reboots then reverts to the black screen with flashing cursor.

EasyBCD is doing what it is supposed to but what I really want to know is why, only sometimes when I shutdown Vista, something is screwing with the MBR I presume. I don't know what that could be or how to rectify it.

Addendum:

FWIW: Here is the detailed (debug mode) info from EasyBCD after the MBR has been fried and I've had to boot using the Grub Super Disk.

Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=C:
description             Windows Boot Manager
locale                  en-US
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {e8709fb6-fa5f-11db-be4d-e219ece5282e}
displayorder            {e8709fb6-fa5f-11db-be4d-e219ece5282e}
                        {3ceb4653-fdee-11dc-b5a7-00a0d1927a73}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 5

Windows Boot Loader
-------------------
identifier              {e8709fb6-fa5f-11db-be4d-e219ece5282e}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows Vista
locale                  en-US
inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
bootdebug               No
osdevice                partition=C:
systemroot              \Windows
resumeobject            {e8709fb7-fa5f-11db-be4d-e219ece5282e}
nx                      OptOut
pae                     ForceDisable
sos                     No
debug                   No

Real-mode Boot Sector
---------------------
identifier              {3ceb4653-fdee-11dc-b5a7-00a0d1927a73}
device                  partition=C:
path                    \NST\NeoGrub.mbr
description             Ubuntu Linux
 
Last edited:
#7
The only time I run into a flashing cursor for the most part was when setting a storage drive with no OS on it as the default boot device. You could be looking at a problem drive rather then any restoration of the boot information now seeing the syatem fail to start up normally. Bad sectors on the drive. read/write heads not reading properly.
 
#8
I checked the default boot device in the BIOS and it is fine.

I will check the hard drive for errors, but the reasons I don't suspect a problem with the hard drive are:

  1. The issue has only ever occurred when rebooting from Vista, not Ubuntu. If the hard drive was at fault, you'd expect a reboot from either OS to trigger the problem occassionally. The fact that only a Vista shutdown triggers it indicates to me that Vista or a task I have running in Vista is screwing the MBR on some shutdowns.
  2. The fact that the issue can be temporarilly repaired with any method (Vista Recovery CD bootsect /fixboot, /fixmbr etc or EasyBCD from within Vista) without any write errors seems to indicate that the drive is OK.
Are these assumptions naive?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#9
When i suggested to Repair the bootloader there is more than just EasyBCD to use to repair it. Have you tried the Vista DVD? If you do not have that did you try the downloadable Vista Recovery CD that we provide?

Those will be able to recover the bootloader.

You are right about the assumption that Vista or something with in Vista is causing this. With the fact that there is no repair option built into Vista the repair the bootloader, which should work if you use the DVD or CD and run it twice, will be your only hope.
 
#10
But as I said, I can repair the bootloader using EasyBSD or the Vista Recovery CD but the problem is that it doesn't last for more than 2-3 reboots, whereupon I have to repair it again.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#11
Can you run a check disk?
 
#12
I would recommend that as well as drive diagnostics tool provided by the manufacturer. For Western Digital that would be the LifeGuard tools. The diagnostic tools have their own stress tests as well as disk surface scanning tools similar to what the check disk tool does in Windows.

The continuing reset of the boot loader to something else on it's own is only seen when something makes a change like an intentional change you might make. In order to see the Grub loader used for ubuntu replaced here so that the Vista loader becomes default again for the Vista/XP dual boot I have to manually remove the additional boot file for that as well as see the Vista mbr restored. Otherwise Grub still brings up the boot menu for ubuntu with the Vista loader seen there as an option.
 
#13
OK. I have upgraded the BIOS, run full memtest and hard drive diagnostics. All tests passed. My problem still exists and is slowly driving me mad ... :angry:
 

mqudsi

Mostly Harmless
Staff member
#14
I'd guess there is something wrong with your Ubuntu installation and that it attempts to rewrite the MBR each and every time?
 
#15
I'm starting to believe it's a clash of some type between Grub and other boot loaders. When installing ubuntu was that a live version using the install to drive option there or an install only release?

The change here was using the install option seen on a live release now seeing problems loading XP while Vista will still load right up when selecting the Vista loader option. If you don't highlight and press one of the boot options within so many seconds the screen goes black until hitting the ctrl-alt-sel key combination to see ubuntu then start loading.