Dual boot: Vista\Vista laptop with eSATA

#1
I have a laptop hard drive and a fully working eSATA copy [E] both are intentionally identical, so if one fails, I have the other. It's my way of making backups--to an eSATA drive. I used another product for the dual boot, and it works perfectly, about 2 or 3 times out of five. Not really good enough, but when it works, I boot to a menu and it shows both version of Vista, and they both work fine.

But half the time it hangs.

So I want to try EasyBCD. When I go to add the second drive, I select the eSATA drive [F] but the View Settings shows the eSATA as [/U]

There does not seem to be a way to change it. I've had so much grief with this lately, that I'm afraid to save those settings and try it.

I would hope that worst case would boot to the C drive and nothing else, but I don't want another total hang. It took a weekend to fix that.

many thanks
 

Terry60

Knows where his towel is.
Staff member
#2
Hi Robert, welcome to NST.
If the second Vista adds to the BCD as U, just go into "change settings" and change it to the correct drive letter (as it's seen from the system running EasyBCD, not as it sees itself when it's booted)
 
#3
Hi Robert, welcome to NST.
If the second Vista adds to the BCD as U, just go into "change settings" and change it to the correct drive letter (as it's seen from the system running EasyBCD, not as it sees itself when it's booted)
Thank you, I tried that, but it does not change the 'secondary' boot but rather the primary.
So, my laptop C drive is changed to the eSATA F drive.

Addendum:

The U issue becomes this:
There are a total of 2 entries listed in the Vista Bootloader.
Bootloader Timeout: 10 seconds.
Default OS: Microsoft Windows Vista
Entry #1
Name: Microsoft Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows
Entry #2
Name: Microsoft Windows
BCD ID: {c1000b83-f574-11dd-9b74-002354433589}
Drive: U:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

^^^^^^^^
but my sata is F.
If I change settings to F, it become this:

There are a total of 2 entries listed in the Vista Bootloader.
Bootloader Timeout: 10 seconds.
Default OS: Microsoft Windows Vista
Entry #1
Name: Microsoft Windows Vista
BCD ID: {current}
Drive: F:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows
Entry #2
Name: Microsoft Windows
BCD ID: {c1000b83-f574-11dd-9b74-002354433589}
Drive: U:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

^^^^^
It keeps the U drive but changes the C to F.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
You're changing the wrong one.
Pick the second one from the dropdown menu. (you'll see drive U) then change that one.
 
#5
OMG! I kept changing the wrong drop down at the second row. Sheesh, been on this too long. Last Q: if when i reboot now, I should see both options? And if all goes wrong, boot to partitiona manager and restore the MBR? [I like to know there's a workaround]

AND thanks!
 

Terry60

Knows where his towel is.
Staff member
#6
As long as you don't change your main Vista (C) or delete it, you can add/change/delete as many other entries as you want and you'll always be able to get back into Vista and try again.
When you can see you've got your 2 Vistas correctly described as C: and F: (in display settings), you should be all set.
 
#7
Works perfectly! It even allows hiberation in either hard drive, which is something that no other dual boot method or process could manage without problems.

Many many thanks!
 

mqudsi

Mostly Harmless
Staff member
#8
Hey Robert - glad you got everything going & you're most welcome - NST is always here to help :smile: