Dual Boot Vistas

Hey there im new to the forum so hello.

Great Program, been using it for ages never had a prob, till now

Im booting Dual Vistas

One is Vista Ulitmate, the other is a Vista Gamer Version, both x64

I have run my computer like this for a while, but had to both due to drive failure.

I have a 80GB IDE and a 500GB SATA Split 65/400GB

IDE is Disk O and SATA is Disk 1

Vista is Installed on the SATA Drive, and the Gamer is Installed on the IDE For the moment.

But everytime i start the computer up, i get this message

'Invalid System Disk, Replace the Disk then press Enter'

So i put, one of my many Windows disks in and it trys to boot from CD leave it for a bit and then i get the boot Menu up select either one works.

It works fine just its a pain in the ass having to leave the DVD in all the time I Even took the other drive out and just had the one Vista Entry on the Bootloader and it still does it. I tried Reinstalling the Bootloader but i just get the same problem.

Any help wud be grateful.

Here is my overvire of BCD

There are a total of 2 entries listed in the Vista Bootloader.
Bootloader Timeout: 5 seconds.
Default OS: Vista
Entry #1
Name: Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows
Entry #2
Name: Gamer
BCD ID: {14c0c873-ff41-11dc-913f-0019db487a63}
Drive: D:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Mak 2.0

Staff member
Have you tried to repair the Vista boot loader with the DVD?
I have tried all of that apart from Step Four: Nuclear Holocaust

Will give that a go now and see what happens


Nope that didnt work

The first command didnt work

bootrec.exe /fixmbr
but the rest did
Does this mean i have a prob with bootrec.exe?
Done everything it said and that all worked fine, only tryin to run one Copy of Vista at the moment and its still coming up with

'Invalid System Disk, Replace the Disk then press Enter'
Last edited:


Mostly Harmless
Staff member
The bootrec one is the very one you need.

It seems that your MBR is corrupt.... try running testdisk and seeing what it says.
This is the first time ive used this program, so need little help

I got a copy of Ulitmate Boot CD with Test Disk on it, run that and it says that No Partition on the SATA Drive is bootable just both Primary Partions and the IDE has a bootable drive. So i guess im missing that my MBR on my SATA has killed itself.

Is there anyway of Rebuilding it??

Also when i try to start the computer all it comes up with is

Boot from CD:
Boot from CD:
Whats that??


I tried puttin in the Vista DVD again and tried bootrec.exe /fixmbr and it worked, but when i try to boot into windows without a CD i get this 1234F: as above and it wont do anything.
Last edited:


Mostly Harmless
Staff member
Check the boot device order in the BIOS.