Dual boot Win7 64bit & Ubuntu 9.10 64bit

#1
I ran into a strange problem trying to setup a dual boot with EasyBCD 2.0 build 76 and Win7 64bit and Ubuntu 9.10 64bit. When I try to boot Ubuntu it drops to Grub4dos grub prompt and cannot find a boot partition.

I have 1 drive with Win7 first, a separate NTFS partition for shared space and Ubuntu after that. So my partitions looks like this:

Win7 W:\ boot (100mb)
Win7 C:\ (250 gb)
NTFS D: (800 gb)
Linux ext4 (320gb) /sda5
Linux swap (5mb) /sda6

I have actually done this almost exact boot a couple of times and no issues before. The only difference here is 64bit OSs but I doubt that has anything to do with it.

I verify I had a good Ubuntu install I booted to the live cd and repaired the grub boot loader and the system booted fine to the Ubuntu Grub menu and loaded fine. In fact I could boot Win7 from there as well no problem but I really wanted the Win7 / EasyBCD loader instead.

Any ideas if I missed something or what went wrong. If I cannot resolve I may just put in a second drive instead but hate to do that if not necessary. Oh and I am not running Raid, I have just a 1.5TB drive.

Thanks.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Ubuntu 9.10 uses grub2.
Delete the current linux entry from the BCD
Add it again, select grub2 from the dropdown
(all options will "grey" - they're not needed - Easy2 will find what it needs)
 
#3
Hi Terry, thanks for the reply. I am using Grub2 and successfully completed a couple of other Windows / Ubuntu configs.

After sleeping on this I am pretty sure this is NOT a EasyBCD problem. I will prove my theory this afternoon but I think this is a primary partition problem. I thought I was at 4 primarys but I think there is a phantom in there besides the Win7 100mb. From grub prompt I did a find late last night and it does not find the partition that Ubuntu is on but I know I can boot from it if the boot loader is loaded on hd0,0.

I think I need to either delete the extra NTFS partition or the little Win7 100mb or go to a second drive which was my preference to begin with but did not have one.

I will report back but pretty sure this is my own config problem.
 

Terry60

Knows where his towel is.
Staff member
#4
Make sure you Easy2/ Diagnostics / Change boot drive, to copy the W7 boot files into C: from the unlettered drive, before you get rid of it.
 
#5
Just to close out this issue, it was indeed a primary partition problem. Ubuntu really wants the bootloader to be on a primary. It seems there is a phantom primary partition and it is not the Win7 100mb because I know about that and I always give it a drive letter W:

My resolution was to add another drive instead of changing the other partitions. I prefer to have the OSs on separate drives any way when I can.

So this was my own problem and NOT EasyBCD :smile: