dual boot window 7 and window 8

#1
I have window 7 and window 8 on two separate drive and found out about easybcd..so I installed it to dual boot between the 2of them..but now each time I want to boot with window 8 I get a weird message that I don't understand ..now if I want to use window 8 I must unplug all drive and leave only the one with window 8.Can somebody explain where I went wrong and how to remedy the problem ( window 8 is the upgrade offer from Microsoft to upgrade window 7 to window 8 PRO)thank you for any help
 

Attachments

Terry60

Knows where his towel is.
Staff member
#2
#3
Thank you Terry60 for getting back... I got the thread you gave me but I already read it before doing my post and I don't really think it relates to my problem (I did not install W8 from scratch but as an upgrade from W7...did copy W7 on a separate drive using Acronis then upgraded to W8 Pro ..) .if I unplug W7 after deleting the W8entry in easybcd I can start W8 ..... Now should I also install easybcd inW8 and add W7 on it ( I haven't done this....)
thank you for your answer and time
 

Terry60

Knows where his towel is.
Staff member
#4
The Invalid Digital Sig message occurs when you try to boot W8 with W7's bootmgr.
Change your BIOS to boot from the W8 drive first instead of disconnecting W7 completely.
Then add a W7 entry to W8 bootmgr's BCD.
 
#5
hi terry , I think I have a problem with your solution..in my bios I have no choice of drive for booting ..I just get boot from drive/cdroom/etc but no choice for which drive ...now I tried a window 8 repair with the cd from the upgrade but I get different result depending on which option I choose , either " the drive where window is installed is locked .unlock drive and try again " or "unable to reset your pc . a required drive partition is missing " .then I try a reinstall but there I hit another problem as window is asking me for a reg.key but as it was an upgrade from window 7 the cd did not have a reg key...what must I do now thank you very much for your help...much appreciated
 

Terry60

Knows where his towel is.
Staff member
#6
If your PC BIOS won't let you swap the order of HDDs (Dell ?), then physically switch the cables between the drives.
 
#7
hi Terry60 , thanks for getting back. No it is not a dell ..it is home build pc ..the motherboard is an " ASUS M3N-HT Deluxe Series" with a quad core processor and 2 NVidia graphic cards- 8gb memory -2x 500gb hard drive and 1 x 1TB hard drive ..may be if your read the booklet about it you can tell me if I am right in saying that there is nothing in the bios which let you choose which drive to start with ...maybe I am getting something wrong somewhere ( to be sure "in the Bios ..you mean the page that comes up when at start up logo , before window you press delete and get the page where you control everything ...like boot drive etc...just to make sure..)
 

Terry60

Knows where his towel is.
Staff member
#8
Yes, and since you have an ASUS mobo, like I do, it'll have a Phoenix Award BIOS.
That definitely lets you change the HDD boot sequence.
The boot priority is a tree structure.
You tell it at the top level that CD comes before HDD for example, but at the next level you specify, which CDROM to select first if you have two (as I do), and what the relative priorities of the various HDDs are.
Play around a bit more and you'll find it.
 
#9
hello Terry60, thanks for your reply and patience.If I understand what you are saying ishould be able to decide in the bios what HHD to start first and again if I understand what you are saying I should be able to do this under the heading "hard Disk Drive"...I am going to try it and let you know how it went ..never did this before ...new to me did not know you could do this ..thanks again
 
#10
hello Terry60...well I tried but cannot understand how it can be done ..went in the bios=> boot=> found the different categories( boot device priority/removable drives/ hard disk drives etc)..under boot device priority => 1st boot device / 2nd boot device etc..next under each boot device => removable/hard drive /cdrom/disable....here I can only choose one of the option...under category hard drive => I can see my 3 hard drive ( 1.sata4 ST...../2.sata 1 ST..../3.sata 2 SAMSUNG HD....) on the side it says " use <arrow up> or < arrow down > to select a device , then press <+> to move it up or <-> to move it down the list " but nothing happen when I press + or -... am I at the right place to set which drive to start ? sorry if I ask a lot o question but it is new to me this ..thanks for your help and patience
 

Terry60

Knows where his towel is.
Staff member
#11
Did you use + and - on the numeric keypad ?
 
#12
hi Terry60..well I use this time the numeric pad and it works ..ho wonder ..now I suppose I should go back to the W7 drive , uninstall easybcd, go back to W8 drive install easy bcd with W8 as "default" . is that the right way to do it or should easy bcd install on both drive with W8 as " default"?
 

Terry60

Knows where his towel is.
Staff member
#13
EasyBCD is just a utility which sits on your PC doing nothing (except taking a little space) unless you start it and use it to make changes to the BCD.
It doesn't matter if you leave it on W7 or uninstall it.
Just boot W8 and install EasyBCD (or just call it from wherever it resides on W7 with a shortcut on W8), then add a BCD entry for W7 to the W8 BCD.
Take note of this thread though as you'll find the "boot" behaviour of W8 slightly strange
 
#14
hi Terry60..well that is it my dual boot is working fine now ...ok W8 is slow to load but I can now choose either W7 or W8 so you resolved my problem with my biggest thanks to you

Addendum

hi Terry60 ..well just an update this morning when I started the pc it went straight to W8 without the option of easybcd so I change the default setting in easybcd and put W7 as default and it seems to work ..I have now the choice when I start ..I am still , in the bios , with the start drive as the one using W8..you see I night I turn the power so I don't know if that is the problem but tried several time turn on and off and I start with the option ..just wanted to let you know ..thanks again for all your help
 

Terry60

Knows where his towel is.
Staff member
#15
Did you disable "fast boot" in W8 power options as mentioned in the other thread I linked ?
 
#16
Hi terry60..no I did not disable "fast boot " as I could not understand how to do it ....what is happening is that when I turn the power on the pc for the first time everyday it goes straight to W8 so I do a few thing on it then turn it off and restart ..at that time I have the option of easybcd for booting with W8 or W7..it is abit of a pain but I don't want to mess it up as I don't understand the article in the link you gave me ..sorry but it is too " literate" for me ..(it is funny but when I turn the pc off and restart it I have no problem to get the option of easybcd but when I finish at night and turn off the pc I also turn off the main to the pc ..and in the next day it happen straight to W8 ) ..maybe you know another thread where the explanations are more in "plain english"..thanks
 

Terry60

Knows where his towel is.
Staff member
#17
W8 neither shuts down when you tell it to, nor boots when you turn it on.
It secretly hibernates when you tell it to shut down, and when you turn it on it pretends to boot, but really just resumes from hibernation.
If you call its bluff and ask for a different boot option, the only way it can get from "inside W8 pretending that it's really outside" to a place where it can start an alternate OS, is to actually shut down W8 and then really reboot so that it gets to the boot menu it was pretending to be at before.
Then when you make the boot choice it can comply with your request.
Fast Startup - Turn On or Off in Windows 8
 
#18
hello Terry60..no I did not because I could not understand the article in the link you send me ..but once I saw your question I did a google search and found several "plain English " explanation on how to do it so did it and it is working fine now ..perrrrfect thank again for all your help and patience
 
#19
hello Terry60 , sorry for being so late answering you . at first when I read the link I could not understand it . so when you ask if I did disable "fast boot " I did a google search and found easy explanation on how to do it ..so I did it and it working like a charm ..no more problem Window 7 or window 8 as I want ..perfffect thanks again for your help and patience