Dual Boot Windows 7 and Ubuntu 9.04

daande

New Member
So I installed Ubuntu 9.04 then installed windows 7. Next, I download easyBCD 2.0 to try and add ubuntu 9.04 to the boot list. I have so far been unsuccessful in being able to boot from ubuntu. Note: This is on the same Harddrive and when I select ubuntu from the boot menu all I see is a blank screen with a flashing cursor. Any ideas?
 

Terry60

Knows where his towel is.
Staff member
Hi daande,welcome to NST.
Did you tick the "grub isn't .... "box ?
It's not needed when linux and Windows share a HDD.
 

daande

New Member
Hi daande,welcome to NST.
Did you tick the "grub isn't .... "box ?
It's not needed when linux and Windows share a HDD.
No I did not I will try it now and let you know how it works out.

Addendum:

So that did not work I got a msg something something like hd(0,0) EXT2: _ Any idea how to fix that?
 
Last edited:

Terry60

Knows where his towel is.
Staff member
Sorry you misread my post. Note the "not"
I was checking that you hadn't, not telling you to tick it.
Are you sure you selected the correct Linux partition from the dropdown menu.
You must select the one that you installed grub to.
 
Last edited:

daande

New Member
Yes well then I had it correct in my first post. So it goes to a blank screen. Is this any help:

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=\Device\HarddiskVolume3
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {95bbac6a-5f15-11de-ace4-ab79ee61f786}
resumeobject {95bbac69-5f15-11de-ace4-ab79ee61f786}
displayorder {95bbac6a-5f15-11de-ace4-ab79ee61f786}
{95bbac73-5f15-11de-ace4-ab79ee61f786}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 30

Windows Boot Loader
-------------------
identifier {95bbac6a-5f15-11de-ace4-ab79ee61f786}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {95bbac6b-5f15-11de-ace4-ab79ee61f786}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {95bbac69-5f15-11de-ace4-ab79ee61f786}
nx OptIn

Real-mode Boot Sector
---------------------
identifier {95bbac73-5f15-11de-ace4-ab79ee61f786}
device partition=C:
path \NST\nst_linux.mbr
description Ubuntu 9.04



I select the option that says Linux

Addendum:

Any Ideas?
 
Last edited:

Coolname007

New Member
Did you point the Linux entry in EasyBCD at Drive 1, partition 1?

Addendum:

Change the boot sequence in the BIOS, to put the Win 7 and Ubuntu HDD first.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
Is your other drive (the one displaying as disk 0) an IDE HDD, and your OSs on a SATA ?
If so, this might be a problem that should be fixed in Easy2, that was discovered back in 1.7
It's a problem with Vista numbering IDE disks before SATA, even when the SATA is 1st in the BIOS boot sequence and is disk 0 to all boot managers.
Since Easy gets the numbers from Vista, it causes problems, which I thought had been overcome in release 2.0.
Try amending the hd(1,x) in the NST\menu.list, to hd(0,x), and see if that fixes the problem, or you could try to "fool" the code by deleting the Linux entry and pointing at the other (wrong) disk in the dropdown menu as you add it again, which should make the same change to menu.lst itself.

Let us know if that's the problem and if it is, what build of Easy 2 are you using ? Is it the latest (63) ?
 

daande

New Member
I have a SATA HD on this laptop thats it. that Drive 0 could be my turbo Memory that I have 2GB of I know that is considered a harddrive maybe. Anyways, Terry60 can you please be more specific on which you want me to try and Yes I am using easyBCD 2.0 build 63.
 

JustinW

Super Moderator
Staff member
Yes, usb drives well count as other hard drives in the system. Make sure its not plugged in as you're booting.
 

Terry60

Knows where his towel is.
Staff member
Take the USB drive out, and delete/add the Linux entry again.
 

daande

New Member
I do not have a USB Drive. I Have that built in intelTurbo memory that can be used to speed up harddrive seek times or as extra ram.
 

Terry60

Knows where his towel is.
Staff member
To enlarge upon post #7, I think your turbo memory/pseudo HDD might be confusing Vista (and through it - EasyBCD). It's listed in disk management as disk 0 which is what the bootloaders recognize as the booted drive.
If so the menu.lst file in the NST folder might be mistakenly referring to hd(1,x) when it should be (0,x).
Just change that 1 digit and see if Linux boots.
 

JustinW

Super Moderator
Staff member
If the file's blank you need to re-add for sure. EasyBCD -> Add/Remove Entries -> NeoGrub - Uninstall NeoGrub. Than click the linux tab and re-add.
 
Top