dual boot with 2 HDD

#1
Hi,

I downloaded the free version of easyBCD2.0.2 becasue it is suggested that I should use this software to change my boot sequence.
I installed win7 on my first HDD and install fedora 14 on the second HDD.
After fedora installation, boot to win7 and download easybcd and change the bootloader as suggested from a linux forum.
here is my output from easybcd:
There are a total of 2 entries listed in the bootloader.

Default: Windows 7
Timeout: 30 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Fedora 14
BCD ID: {01da901c-cf28-11de-bda8-be141da3f038}
Drive: C:\
Bootloader Path: \NST\nst_linux.mbr

So when I selected fedora 14 on the boot sequence, I get blinking minus sign at the top left corner of the screen and nothing happen, select win 7 system starts up o.k.

please help fixing this.

thanks
 

Terry60

Knows where his towel is.
Staff member
#2
Did you tick the "grub isn't....." box when you added the Linux entry ?
(needed when the OSs are on different HDDs- see sticky point 7)
 
#3
Terry60,

I was wondering if it would have been possible to instruct Fedora to install grub to the second hard discs MBR?
 
#4
Hi,

So when I checked "GRUB isn't installed to MBR/bootloader", checking fedora 14 for boot I got
"error 14" and "file system type is ntsf".

How do I tell GRUB to install on the second HDD?

thanks for your help.

Pom
 
#5
Dogrun,


As Terry60 pointed out because Easy BCD should be able to pick up the boot option for Fedora, it is unnecessary to mess with installing GRUB-1. However, I was just curious. The option for where to install the MBR should come up right after you get to the screen where you accept the partition in the Fedora 14 install process. I don’t know whether or not you can actually install GRUB-1 to the second hard drive or whether it would work.
 

Terry60

Knows where his towel is.
Staff member
#7
If it says filetype is NTFS, you must have picked the wrong partition from the dropdown.
Select the one that says it's Linux and tick the box.
 
#8
I think my problem is probably from there is no letter assigned to my fedora HDD from Win 7 disk management (see the doc file). I will assign a letter to this drive and redo the easybcd again. I hope this solved my problem, do not want to reinstall fedora again.

thanks
Pom
 

mqudsi

Mostly Harmless
Staff member
#9
Nope. You can't assign a letter to a Linux partition.
 
#10
Yes, Computer Guru you are correct, I can not assign drive letter to Linux partition.
As you can see from the attached screen dump info I posted earlier, Disk 1 is my Linux disk but it has no letter assigned to it and this is why easybcd does not know where the linux boot partition is, am I correct?
Do I have to reinstall Fedora all over again????Help

thanks
Pom
 

Terry60

Knows where his towel is.
Staff member
#11
No. Just select the Linux partition from the dropdown if the Linux shares Windows HDD.
For separate HDDs, tick the box and EasyBCD will do the locating for you. No need to specify a partition.
 
Last edited:
#12
HI,

Thanks for all of comments on this post.
I decided that I do not want to waste any more of my time on this.
So I will have to hit F12 every time I boot my desktop and select which HDD
I want to boot, lucky that the boot section for both win 7 and fedora 14 are still in
tact on each HDD.

I have too many software installed on fedora and do not want to reinstall everything.

thanks everybody.

Pom