Dual booting - but with errors

#1
:wtf: Hello again, back with more confusement. Hoping someone can help with a pesky problem.

I have Vista and Fedora 11 x64 KDE dual booting, but getting errors.
Using EasyBCD 1.7.2

Bit of history... I have one SataII drive - three partitions. C:\ 40gb for windows, D:\ 125gb for documents (I move default locations to second partition (which is also backed up to USB HD) so that clean system installs don't mess up all personal data, and have my eyes on 7 when released), and an un-allocated space of around 40gb at the end for Linux distro installs.

Previously had Vista and PC-BSD dual booting using NeoGrub and the edited menu.lst method, the only fly in that ointment was pc-bsd doesn't support either my Broadcom LAN or the intel 4965 wifi devices and cant recognise them.

So decided to replace PC-BSD with Fed11x64KDE....

Gparted live CD 0.4.6-1 (used torrent to download, also double checked checksum, and burn at slowest speed, and used its own integrity check before any partitioning/installs - Same routine for Fed 11 DVD). Two copies of everything.

Used GParted to delete previous PC-BSD partition leaving un-allocated space for Fedora install.

Installed Fedora. MBR re-written just to boot Fedora.

Reboot, using Vista recovery disk to bootrec /fixboot and /fixmbr via command line (/rebuildBCD would not work at this stage)

Rebooted, got a No System available message, nothing boots.

Reboot with GParted to set boot flag back to C:\ (Doh!)

Reboot, tada!, Vista back online.

EasyBCD, NeoGrub.... oops didn't copy menu.lst from fedora...

Reboot with Fed 11 live DVD to get access to all partitions and copy over menu.lst

Reboot into Vista, EasyBCD, Neogrub, Edit config, paste in fedora entries adjust timeout, boot order etc...

Tada! Vista and Fedora 11 dual boot again.


Now heres the problem, after choosing Fedora NeoGrub loads, and I get a message repeated three times (more on this in a minute), followed by the Boot options as detailed in the menu.lst which all executes fine, even chainloading back to Vista if I change my mind... Fedora works in all its Plymouth Leonidas goodness - Its just that message which is bugging me....

"Warning Unrecognised Partition table for drive 80. Please rebuild it using microsoft compatible FDisk tool (Err=26) Current C/H/S=16383/255/63 (Hd0,0) Filesystem type is NTFS partition type 0xb"

Fedora is on Hd0,2 which my menu.lst points to for the fedora kernel entries, so the errors being detected by neogrub when it launches are on the C:\ partition?

Unsure at this juncture whether to just leave it alone or not (after all both OS are working fine otherwise, its just annoying having an error I am not sure about and it offends me at every boot of Fedora).

I did experiment with using Grub (Both checked and unchecked for the Grub installed on this partition option) instead of NeoGrub, but only Neogrub and the custom menu.lst seems to be able to launch Fedora successfully.

Anyone come across this error before?

Addendum:

SOLVED

:smile: And probably better than previous method, had a read around some other problems and noticed a few talking about the beta version of EasyBCD (I normally shy away from betas when it comes to such important tasks as partition/boot management)

Installed the 64 build, deleted neogrub entry, and re-tried Linux Grub, noticed the drive selection dialogue and the list of partitions has changed order slightly, and the linux partition in particular has been recognised differently now. Checked the box for not installed, re-order, save etc etc

Reboot... Success, no error warning.

I say probably better above because now I believe any updates to the kernel while linux is loaded will now not have to be re-entered into the old menu list for NeoGrub, and should henceforth just boot after updating?

Something else I notice with using this version, previously using Neogrub option in EasyBCD 1.7.2 - using a splashscreen for the menu choice always looked slightly corrupted (or maybe the wrong screen resolution for the splash image) - Now after updating to the 64 build of the beta EasyBCD and using Grub that little quirk has also been resolved, the splash screen looks as it should.

Thanks for the work going into this tool, its made changing distros and keeping dual boots going a lot easier. :nerd:
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Glad that 2.0 did the job for you.
The sticky thread does make it clear that you can't use 1.7 for linux builds later than Ubuntu 8.04. (and other distros of a similar vintage)
Grub syntax changed, and the support for it doesn't exist in 1.7 which pre-dates the change considerably.
EasyBCD is not the bootmanager/loader. It's the boot manager's manager, a utility with a GUI to manipulate BCD entries without needing to know BCDedit command-line syntax.
It also contains lots of extras to facilitate non-MS customization like OSX and Linux, but it's not the bootmanager. It just allows you to manipulate other boot managers to work together.
Your spash screen(s) are coming from one or other of them. Nothing to do with EasyBCD.
 
#3
Thanks Terry, yep understand the splash screens are sourced from within the distro setup, but whilst setting up dual booting first Ubuntu, Fed 10, PC-BSD and the latest Fed 11, before dual booting was set-up, and launching from the installed grub by the distro, the splash screens in all instances were fine, but then only looked corrupt after using NeoGrub after setting up dual boot.

Which led me to believe Neogrub to be the source of splash screen problems, and in those instances did not use splash screens.

Anyway no-longer a problem. I think I have been a bit lax following the development of EasyBCD, and really I am still learning, Ubuntu 8.04 was my first introduction to linux but sometimes an update for instance would no longer support NVidia (I think it was Ubuntu 8.10, and at the time Fedora had advanced beyond the problem so I changed over). Still have to keep windows around for the families games, otherwise it would be history.