Dual-Booting Ubuntu Linux(instead of XP) and Windows 7(dual HD,Windows bootloader)


Hi all,

this :

Dual-Booting Ubuntu Linux and Windows 7/Windows Vista (with the Windows boot loader)

is what I want to do.I have XP and Win7 in a dual boot config after installing Win7 upgrade on my old XP PC (see disk manager screenshot) I would like to install Ubuntu (10.10 or so) instead of XP with the fewest/smoothest steps possible. Can Easy BCD really make this painless?


  • Diskman.JPG
    72.5 KB · Views: 7
After EasyBCD > BCD Backup/Repair > Change boot drive, to copy the boot files across to W7, remember to change the BIOS boot sequence to boot from the W7 HDD.
W7 will then be "active" "system" "boot" and you can proceed with junking XP.
that went without a hitch:


I wonder about the small unallocated "room" on my XP disk though. I also have trouble starting my PC from the Ubuntu "live USB stick". It seems to work, but then stays in the purple ubuntu splash screen like forever... Found on the web that this may be because of smart card reader, removing that now...


  • Diskman.JPG
    31.5 KB · Views: 24
Last edited:
I don't understand - the XP partition is still there? You should delete it entirely (right-click -> delete)
I had not done that yet but have now. Ubuntu now starts ok without the smart card reader... proceeding to install now
Well, everything went smooth until now, but....

Small problem to finish Ubuntu 10.10 install, apparently you can't use capitals in your user name...

Bigger problem when starting Easy BCD:


So what do I do now?Is this because of the two hard disks?I don't think I did something wrong...


  • Bootconf.JPG
    23.3 KB · Views: 22
Last edited:
OK, figured that one out a bit, apparently it's hidden somehow (Can see it in Ubuntu, not in Win7), but if I manually give Easy BCD the path: C:/boot/BCD, it works, once... iReboot can't see a thing either though...

This is what I have now:

There are a total of 2 entries listed in the bootloader.
Path: C:\Boot\BCD

Default: Windows 7
Timeout: 30 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7
BCD ID: {default}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Ubuntu Linux 10.10
BCD ID: {5bbe6584-3468-11e0-8a37-0011b107a235}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub0.mbr

With the longer timeout I can now actually see the Win7 dual boot screen, and when I choose Linux Ubuntu actually starts (with Grub2).

But , even though I now have the boot directory and files unhidden, and editable by Easy BCD, it still cannot find them at startup and iReboot does not give me any options either. So both operating systems work , so do both boot loaders, but it ain't pretty.

Would it be ok to proceed with the next step:

Go to the "Setup Bootloader" page in EasyBCD, and select "Install the Windows Vista/7 Bootloader to the MBR" then press "Write MBR"?

and would this solve the Easy BCD startup problem and the iReboot choice?What could go wrong?
Last edited:

I did just that, saw that somewhere in the process my hard disks must have gotten switched around again, so I rebooted , put them correct and followed the steps for setting the timeout in grub2 to 0 and what do you know, it now all works as advertised! Easy BCD finds its files, iReboot lets me choose between Win7 and Linux , so does the Win7 boot loader, and Grub2 is no longer visible.I'm a happy camper...

By the way, this is only my second Linux distro, and I have to say there's no comparison to my Suse Personal 7.3
It's annoying (and I don't think it used to happen on the BIOS of my older mobos), but whenever you boot with a HDD disconnected, it switches the boot sequence to favour the last-booted OS, and you have to remember to reset the sequence when you finally boot with everything in place.
As far as I remember, older BIOSs , if set to boot HDDA, HDDB, would boot from B if A was disconnected (deliberately or through a bad connection) because A was not available, but as soon as A was reconnected, it would resume precedence.
Now you must manually reset the sequence.
I liked the old way better.