Dual Booting Windows 7 and Backtrack 4


I had the laptop with dual booting using GRUB, everything going fine, but I wanted to use truecrypt, and it would only work if I used windows boot loader. So I installed easyBCD, latest beta build.

Here's my grub menu.lst:

## ## End Default Options ##


title Backtrack 4 , kernel
uuid 78095887-5c93-4aab-a865-853e3e56562f
kernel /boot/vmlinuz- root=UUID=78095887-5c93-4aab-a865-853e3e56562f ro quiet vga=0x317
initrd /boot/initrd.img-

title Ubuntu 8.10, kernel (recovery mode)
uuid 78095887-5c93-4aab-a865-853e3e56562f
kernel /boot/vmlinuz- root=UUID=78095887-5c93-4aab-a865-853e3e56562f ro single
initrd /boot/initrd.img-

title Ubuntu 8.10, memtest86+
uuid 78095887-5c93-4aab-a865-853e3e56562f
kernel /boot/memtest86+.bin


# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Windows 7
root (hd0,0)
chainloader +1

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda2
title Windows 7
root (hd0,1)
chainloader +1
First I've tried using neogrub since it doesn't affect the bootloader, but every combination that I've tried didn't work. My linux logical partition is on partition 4.

I've also tried adding a linux entry directly, with grub legacy, but the screen goes black and nothing happens.

Grub2 goes to a command line.

Right now I can only use Windows 7 and no linux =/ All this because I wanted to use truecrypt on my drive lol

I'm only using a drive, btw.

Any help would be greatly appreciated!

Last edited by a moderator:


Knows where his towel is.
Staff member
Hi Coder, welcome to NST.
That's legacy grub (menu.lst), so forget all about selecting grub2.
Delete the previous attempts at setting a Linux entry
Select legacy grub, point the drive dropdown menu to the Linux partition containing the grub installation, and tick the "grub isn't...." box only if Linux is not on the same HDD as your W7 bootmgr.
Last edited:
Thank you for the welcome and help!

I've already done that. I've restarted the pc for each entry that I created.

When I select legacy grub and choose Backtrack it simply goes to a black screen, like another user reported here. I only have a HDD on the laptop, so I've never ticked that option.

I don't know what do to make it work, nor how to get my bootloader back, without formatting that partition.


Mostly Harmless
Staff member
It's possible that backtrack doesn't use a standard GRUB configuration that is supported by EasyBCD.

Let me look into this issue and get back to you.


Super Moderator
Staff member
Backtrack 3 was using Syslinux (not sure if its using it now) but I'm booting it off a USB drive no problems with grub4dos. One problem I can already see is that your uuids in the menu.lst you provided are exactly the same for both Ubuntu and Backtrack. You should place dummy files on each partition, like "Backtrack.ID" and "Ubuntu.ID". Then your menu.lst would look something like this:

title Backtrack 4 , kernel
find --set-root /Backtrack.ID
kernel /boot/vmlinuz- append vga=0x317 initrd=/boot/initrd.img-
initrd /boot/initrd.img-

title Ubuntu 8.10, kernel (recovery mode)
find --set-root /Ubuntu.ID
kernel /boot/vmlinuz- ro single
initrd /boot/initrd.img-
If its any help, here's what my Backtrack 3 entry from my USB looks like. Its a little different cause I have it copy itself completely into memory at boot and its non-persistent:

title BackTrack 3 - Copy to RAM
kernel /boot/vmlinuz append vga=0x317 initrd=/boot/initrd.gz ramdisk_size=6666 root=/dev/ram0 rw copy2ram autoexec=xconf;kdm
initrd /boot/initrd.gz
kairozamorro my BackTrack and Ubuntu entries are the same, because they're the same OS. The latest version of BackTrack is based on Ubuntu. I just changed the name to BackTrack.

The entry doesn't look much different =/
Thanks for the help, though.

Maybe I'll just format the linux partition and reinstall it.
Last edited:
Did you try it though?
Using Justin's method will search all partitions for the ID file, instead of relying on the UUID. Sometimes this method works, while the other fails.
Nop, I didn't try it yet.
I've managed to restore my old bootloader and everything's working fine.

I'll give it another try on vmware when I have more time to test, again.

Thank you for your help!