Dual booting Windows seeing new HDD - and not seeing it

#1
I have installed a new SATA drive in the third flexbay of my Dell Precision 490 WS.

I am dual booting XP Pro and Win 7.

The BIOS sees the new drive and at first I formatted the drive in XP. when I switched to W7 the drive was recognised in Computer but when I rebooted to see if it all still worked although W7 eventually saw the drive the partition had gone. It asked for it to be initialised but could complete this due to I/O error in Virtual disk Manager. Rebooting into windows either XP ot W7 than takes a LOT longer but I cannot access the drive through Disk Management.

I have disconected drive and tried other SATA connections on the board but still the same result yet once I did this and went straight into W7 the partition WAS recognised - until I rebooted again.


I am assuming this is some kind of windows conflict - or not?

Any ideas gratefully received.

The first two drives on my system are a pair SAS drives.
 

Reimar

New Member
#2
Did your MB's BIOS supports AHCI and is it enabled?
 
#3
Thanks.

it does but it has been set to auto raid/ata detection rather than the factory default of auto raid detection/ ahci. Would that be it? Or will it cause other problems
 
#4
Hi iockus,
if the OS (XP) installed without AHCI and the BIOS was without AHCI, the OS running still.
If you change later the Bios to ACHI without changing the OS to AHCI, the OS (XP) will not boot up to finish.
If you change the BIOS later to "no AHCI" and your OS (XP) is installed with AHCI, your OS will not boot up to finish.
You can found much information about this in the Net
You must change first the OS and then the BIOS setting: ALL to AHCI or ALL to "no AHCI".
Win7 work not with AHCI, only XP and, I think so, Ubuntu.

Greetings from Germany,

STRUPPI
 

Reimar

New Member
#5
Struppi:

You're wrong. Windows 7 works with AHCI very well! It's mainly used for "Hot-Plug" SATA hard disks while running the OS. That simply means that you can connect or disconnect SATA HDD's while running and working on the computer. Special if you use eSATA drives it has it's advantage.

iockus:

OK, here's a tutorial how to work (enable) with AHCI:

AHCI Advanced Host Controller Interface makes NCQ Native Command Queuing along with hot-plugging or hot swapping through SATA Serial-ATA host controllers possible; Vista was the first to offer this feature. The issue with AHCI is it needs to be enabled in the BIOS prior to OS installation; doing so after you have installed the OS will disable the PC. The reason why is Windows disables the AHCI drivers not needed durring installation.

This tutorial will show you how to enable AHCI after you have installed the OS.

Warning:
Changing values in the Windows registry can disable your machine; if you're not sure how to do this please post a question in this tutorial and someone will be glad to help you.

Information:

This method will also work for Windows Vista though the default DWORD string value in Vista will be "4" where it will be "3" in Windows 7.

Note:

As a precaution it would be a good idea to create a "System Restore Point" before you start this.


OK, here we go:

1) To get started, in the start menu start search box type "regedit" (without the quotes) then r. click regedit and click "Run as Administrator" then enter your user credentials for the UAC prompt then click yes.


2) In regedit navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services, click "msahci", in the right pane r. click "start" then click "modify" ...

3) In the window that opens change the value to "0" and click OK.
To close regedit click "File" at the top left and cilck "Exit".

4) Now you'll need to restart the PC and go into the BIOS and enable AHCI; when Windows boots up it will finish installing the AHCI drivers.

5) You will need one final restart to finish the process after the drivers are installed.
 
#6
Hi Reimar,
YEP (Yes), it is right what you wrote.
I will test on my x64 nVidia-Chipset again the AHCI settings.

Thanks and Greetings from Germany,

STRUPPI
 

mqudsi

Mostly Harmless
Staff member
#7
Hi Guys,

I'm using AHCI at home, everything is cool with Windows 7 x64.
 
#8
Thankyou very much.

Before i start on this will switching to ahci actually solve my problem - and why does the ata mode not work?
 

Reimar

New Member
#9
The ATA mode is normally for IDE-HDD and not SATA. The MB of your computer has 1 IDE connector for to connect ATA drives like HDD and/or DVD/CD drives. If the BIOS settings for that IDE port is set to DVD/CD drives and locked, which means not set to AUTO, the MB wouldn't read ATA HDD's and vice versa same is for DVD/CD's.

So first at all: check the settings in your BIOS and make sure that the Settings are set to AUTO. Also enable AHCI if you hadn't done that yet.

Follow the instruction regarding AHCI as pointed in the tutorial.

If you still have problems, check the IDE and/or SATA Data Cable (change them) and check the Power (PSU)
 
#10
Hi Guys,
on my nVidia-MB is AHCI not present, so my Win7 boot with SATA-nVidia-Chip-Driver.
If I change the BIOS setting to SATA-Raid, Win7 boot with the nVidia IDE/Raid-Driver in section SCSI.
Ubuntu and Kubuntu (KDE) work with AHCI on my System, bud I do not know why.
XP is like Win7

My Registry is setting with "0" in all the HD-Driver-Start, this I have did "long" time ago.
There are more points in the Registry to" modification", but finaly:
The (short) instruction what have postet Reimar are OK for AHCI.

My instruction are in German langugage form Windows-Forum.
The Net is full of AHCI-Problems.

Greetings from Germany,

STRUPPI
 
#11
Struppi:

You're wrong. Windows 7 works with AHCI very well! It's mainly used for "Hot-Plug" SATA hard disks while running the OS. That simply means that you can connect or disconnect SATA HDD's while running and working on the computer. Special if you use eSATA drives it has it's advantage.

iockus:

OK, here's a tutorial how to work (enable) with AHCI:

In regedit navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services, click "msahci", in the right pane r. click "start" then click "modify" ...

There is not an entry that says "msahci" as far as I can see?
 
#13
If the MSAHCI service isn't found in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services that means that the service isn't installed.

Make sure that AHCI is enabled in BIOS! after restarting the Computer you should see that the to AHCI assigned HDD('s) on the boot up screen, before Windows starts booting (which means still in BIOS boot stage) and after that while booting Windows, Windows will install the AHCI Service.

The Registry entry should looks like in the attached picture. The Right Click on Start let you change the Value.

Make a Backup of the Registry first would be a good idea!:wink:
 

Attachments

#14
Work gets in the way!

At the risk of seeming stupid - I realize that when i did not switch to ahci in the bios because of the warning 'Attention! changing the settings may prevent operation system from booting etc it didn't occur to me that as the OS is on the separately controlled SAS disks it probably didn't matter. It also says the factory default is ahci so perhaps it had been switched inadvertantly - I don't know.

So, will changing the setting from Raid Autodetect/ATA to Raid auto detect/ ahci do the trick. I really can't afford the time it takes if it all goes wrong but if it is as simple as this it will be great. Will still have to amend the Registry.