Dual-Booting Windows Vista and Windows ME

I tried it again and got Error 17 File not found.
Here is what I typed after the Grub> prompt

Find --set-root /io.sys /io.sys chainloader /io.sys boot
ok, it looks to me like there is an extra "/io.sys" in there.
You have to press enter between each line:

find --set-root /io.sys <ENTER>
chainloader /io.sys <ENTER>
boot <ENTER>
OK, that's why it never worked (even earlier with the boot.ini trick).

Windows ME uses IO.sys to turn on; if you don't have that file.....
OK Here is what I have done. I removed the ME drive and put it back in the old computer and that is what I'm on now. Is there anything that I can do to this drive to make it work in the new computer better. I could not access this hard drive in the new vista computer. I have downloaded easybcd on this hard drive also if that will do any good. I really appreciate your help and don't want to be a nuesance but I really need to get this to work on the new computer.

Of course easybcd does not work says missing dll file mscoree.dll was not found.

I was reading the Neogrub install guide and remember that after the install, the notepad had the commands Find --set-root /io.sys and the other 2 lines were all proceeded by a # sign. Is this why grub can't find the commands ? If so, how do I get to this to change it ?

Which other two lines?

Only text (like comments and explanations) should have a # in front of them. Everything else is a command and must not have the # in front of it.

You can change that by going EasyBCD -> Add/Remove Entries -> NeoGrub -> Configure
Well, they shouldn't.... that's really weird.

But if typing them manually in the console doesn't work, removing the hash sign won't make a difference either.
I removed them and that did not work either. I notice that the external floppy drive tries to start when it tries to boot into grub. For some reason it does not find the ME drive but checks the floppy.

I put the ME drive back in the Vista computer and am now on it.
I know that the drive is recognised because it shows up as G:\ drive and I can open it and see what its contents are. It just is not getting recognised for booting.

Last edited:
The problem is that NeoGrub cannot find IO.sys.

I cannot help with that - if the Windows ME bootloader files are missing, there's nothing that would be able to boot into it.

Try to get IO.sys and the other Windows ME bootloader files from another PC and copy them over - other than that, I don't know.
Thanks, I will work on that. The ME drive boots fine in the old computer so the boot structure has to be there somewhere since it's the only drive in that computer.

Last edited:

That does put a different light on things..

How about adding a line to boot.ini:

C:\=Windows ME

Where C: is the letter of the ME drive?
Pardon me for asking... But why on earth would anyone want to use Windows ME instead of the older, yet vastly superior Windows 2000?
Probably compatibility with some older DOS programs - though I don't know any that haven't been upgraded/replaced with newer NT-compatible versions or competition.

Actually, there was a thread a while back about dual-booting with Windows 98 for compatibilty with a particular program, I suggested the OP try a virtual PC and he said that worked great. IMO dual-booting Windows 9x or DOS is a PITA and since it's no longer officially supported by MS, should be avoided as much as humanly possible.

BTW, welcome to NeoSmart Technologies, Starks :smile:
Well, grab a free copy of Virtual PC from Microsoft, and install it on Vista.

Stick your ME CD (or Disk) in the drive, create a new virtual machine, and start it. Windows ME setup will start from there :smile: