Dual booting Windows7 Ubuntu 10.04

#1
After following the instructions and this forum, I finally got Window and Linux to play nice. However, when I boot to Linux (Ubuntu 10.04) I get a screen that says "Try (hd0, 0): NTFS5: No ang0" that displays for a full 45 seconds. Then it boots to Ubuntu. Because of getting this screen, I thought I was doing something wrong and rebooted before it timed out. I discovered by accident that if I wait 45 sec, it will boot to Ubuntu. How can get rid of this message, or at least shorten its duration?

Some background info:
Windows7 is installed first, then Ubuntu, on the same hard drive. After installing Ubuntu, I couldn't boot back to Windows. Whenever I selected Windows from the Grub2 menu, the computer would just reboot back to the menu. I then used the Windows DVD and ran bootrec /fixmbr to get back to Windows, and, of course, I couldn't get back to Ubuntu. That's when I got EasyBCD to set up the dual boot. It works, BUT I have the above problem. Thanks for any help/suggestions.
Ron
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Interesting!!!

We've had many reports of the bootloader getting stuck on a "Try (hdx,y)..." message - we've had a couple of people report that it doesn't go anywhere when left all night, but I never realized it could, in some cases, go away by itself!

I'll give you something to try, let's see if it does any good.
 
#3
Try what??

"I'll give you something to try, let's see if it does any good."

Mr. Guru,

Thanks for responding. The issue is consistent. The Try (hd0, 0) message seems to stay for excactly 45 seconds every time, then Ubuntu loads.

You said in your response that you would give me something to try. Did I miss it? What are you going to give me??
 
#4
I fixed it. But it got ugly. While doing something unrelated to this problem, I accidentally reformatted the 100MB partition that Windows puts at the beginning of the hdd. I had to jump through some hoops to restore that partition in order to get Windows to boot again. It took some command line fancy fingerwork using the Windows7 install disk, but that's a subject for another forum. Once I got Windows to boot, I reran EasyBCD, and set it up the same way it was before, but this time there is no delay booting to Ubuntu. I don't know what caused it or what fixed it, but it's fixed. I don't recommend what I did for anyone else unless you're a Windows guru and are sure you can get your system back. But if you do, ware safety glasses and a helmet in case of a fatal crash. Or just make sure you're backed up before you start.
 
#6
I have the exact same problem with my eee PC 1000HD. I also followed the guide linked above to dual boot Win 7/unbuntu (Actually the EasyPeasy distro which used to be Ubuntu eee.) Any movement on fixing this issue?