Dualboot Vista 32 & 64 Problem

#1
I have Vista 32 and 64 installed on separate SATA drives and cannot get EasyBCD to give me the choice of what system to boot to.
Presently it is booting to the 64 version and I can only boot to the 32 by disconnecting the HD for the 64. The settings as shown by EBCD in 64 are as follows:

There are a total of 2 entries listed in the Vista Bootloader
Bootloader timeout 30 seconds.
Default OS Windows Vista_64

Entry #1
Name:Microsoft Windows Vista_64
BCD ID: (current)
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #2
Name:Microsoft Windows Vista_32
BCD ID: (23306992-68f3-11dd-81ff-0011e8c192533)
Drive U:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Again from the 64 version Windows Explorer shows the 2 drives holding the operating systems as :

DSK1_VOL1 (C) This holds Vista_64

Drive C (E) This holds Vista 32

I have selected the correct Drive ( Drive C (E) for the Vista 32 settings but note that it is shown as DriveU:\ in Entry2, is this normal or the reason why it won't boot perhaps?

I have also tried running EBCD from the 32 version but I cannot get that to work either.
Any help/suggestions greatly appreciated.

Colin
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
Hello,

You are correct. Having the drive be U is what is causing this issue. Change it to C or Boot and see if that helps.

Cheers,
Mak
 

mqudsi

Mostly Harmless
Staff member
#3
Hi Colin, welcome to NST.

u: is EasyBCD's way of saying "unknown drive" - an entry with an incorrect, non-existent, or corrupt drive property.

As Alex says, just change it to the right letter and you should be good to go :smile:
 
#4
A little progress......

Thanks guys for your feedback which has resulted in some minor progress. Changing the drive to BOOT I now get the option choice of the 32 & 64 versions on boot up (which I did not get before) but every time I select the 32 version it boots into the 64, even setting the 32 version as the default makes no difference it boots into the 64. Don't know where we go from here?

As an aside, as a newbie to this forum and having taken a browse around may I say what a great thing you have going here, none of the flaming and ranting you see elsewhere, just friendly helpful advice, keep up the good work.

Colin
 

mqudsi

Mostly Harmless
Staff member
#5
Sorry, I just re-read your first post and you'll need to set the drive to E:\, not C:\