Easy BCD and Grub2 on Linux Ubuntu

*** Happy Birthday Mahmoud! *** + Thank you for your wonderful software!

I have some debug info for Beta 2.0 build 76 (latest as of today)...also would like to make a post regarding Ubuntu 9.10 problems not fixed by the latest builds of EasyBCD. I would post this directly to the Beta builds thread but it is locked.

I have had no trouble in the past with EasyBCD 1.7.2 doing dual boots with Ubuntu 8.04, 8.10 & 9.04 with Vista using the GRUB option to enable selecting to boot to an Ubuntu installation on separate drives or even different partitions on the same drive...one simply installs the GRUB to the alternate Ubuntu partition/drive vs. the Windows MBR during the LiveCD installation, and then uses EasyBCD to point to that drive/partition...has always worked fine.

Ubuntu 9.10 is a new creature in several regards...GRUB2 and ext4...the latest Betas claim to have full ext4 and GRUB2 support...I think the issue I am having lies with a less well-known addition...9.10 at last has built-in dmraid support for both RAID stripes and mirrors.

Here's my situation: Installed W7-Ultimate-64-bit on RAID stripe array using onboard/"fakeRAID" on Asus M4A78T-E...BIOS 2208...(AMD 790GX NB, 750 SB with RAID option ROM Ubuntu 9.10-64-bit on separate ext4 partitions on same RAID array with GRUB installed to Ubuntu root partition of course...ran EasyBCD 2.0 build 65...selected GRUB2 option...pointed to correct partition...addes entry...reboot...boot menu shows W7 and Ubuntu option...but when I select Ubuntu I just get to a command prompt on a black screen...does not freeze, but does not load GRUB on its own.

I monitored the Beta Builds forum for new updates...installed latest 76 to see if issue were resolved.

Build 76 crashes like mad on this system...reinstalls have not helped: "BootGrabber.exe has stopped working"..."Exception code: c0000374, Exception offset: 000cda83"...this happens whenever one tries to use the Add/Remove Entries screen and selects the Linux/BSD tab....also happens whenever the External Devices button is pressed.

Your forum does not allow me to download a version between 65 and 76 to try another in-between build.

So: Is this likely a dmraid-EasyBCD issue, as others have successfully used the Betas with Ubuntu 9.10 in non-RAID setups? Is it a 64-bit bug? I would love to get this working to at last enjoy Ubuntu on my RAID stripe vs. using a slower separate drive.

Please help.

Thank you very much for your time! Feel free to email me directly if you want more details.


Mostly Harmless
Staff member
*Thank You*

The entire server is currently on the fritz due to the popularity of an HTML5 YouTube viewer we released and the ensuing server load as a result. Soon you'll be able to download any build you want.... sorry about that.

As for my gratitude: thanks for the b-day wishes (had a great day!) and more importantly, thanks for giving me a reliable scenario where BootGrabber crashes. I've been begging testers to give me more info on their scenarios that bring BootGrabber down to its knees, I think dmraid is the solution but I'll have to try it out before we give you The Medal of Honor :smile:

Now most likely, EasyBCD 2.0 will not support dmraid. But it may, it all depends on what I find. (See, if the bootloader code I write doesn't support reading from a dmraid partition, it cannot load Linux in the first place. But, I believe when Ubuntu is configured to use dmraid it will create a separate ext2fs partition that is NOT striped/mirrored for the boot, and if I can load that then all will be fine... and of course, all this isn't possible if bootgrabber is crashing).

Have a nice day, and again thanks a million for your detailed and intelligent post.
You are most welcome...thank you for your kind reply.

I appreciate your efforts...it's probably a bit much to hope for, so early into the life cycles of both W7 and Ubuntu 9.10...and both 64-bit at that!

Just so you know...I did NOT do any command line work to get dmraid to work on my RAID stripe when installing 9.10...dmraid required tedious command line/alternate install CD work on previous versions...a real chore...but 9.10 correctly recognized my array on its own using the default install CD...a real blessing!

I cannot offer any help re: your hypothesis about an ext2 boot partition...over my head...I am principally a Windows geek...no Linux guru.

I will redo Ubuntu on a non-RAID drive for now but leave space on the RAID stripe as I have no doubt that you will figure this out in a future build! Please let me know when that joyous day arrives. :-}


Greetings Computer Guru!

Just noticed you were online now...re: our recent posts about my W7 Ult & Ubuntu 9.10 64-bit issues...the documentation site is up again, but I am still not allowed to download anything but the latest Beta build 76...I made a follow up post with some more info on the dmraid issue...I would really like to try an earlier version (bwteen 65 and 76) but cannot do so...can you grant me access please?

If you would like screenshots of the full error messages I receive in 76 let me know.

Thank you,



Mostly Harmless
Staff member
Hi Jonathon,

It's not a permissions issue.. it's quite random and is a result of a server misconfiguration.
However, I can almost guarantee old builds will not change a thing.

I'm moving the site to another server in a background window as I write this, hope to post an update on the matter soon.

Hi Guru,

Build 65 had the same issue as 76 vis-a-vis the likely dmraid issue, but the app itself was stable...not a single error did I discover...76 in contrast crashes every time on most of the screens. Please keep me posted.


Hi , I just want to add some info from my side.
I have simmilar issue. While having windows 7 I installed windows XP. Restored Vista loader usning beta build 76, and while trying to add entry with Windows XP I recive "bootgrabber.exe stoped working" . It happens in both win7 and winxp. Also no chances to add ubuntu
As mentioned , It problem with me having RAID. Is there any other way to do this manually instead using bootgrabber?
Last edited:


Mostly Harmless
Staff member
I'm unable to reproduce this issue, but perhaps because I did not configure my system the same as you did.

1 hard drive: partition 1 is NTFS for Windows, partition 2 is a software raid volume, formatted as ext4fs in RAID0 (with itself).

Is this your setup? Or do you have an entire drive configured as RAID 0?

I did this with the Ubuntu Server Edition CD in order to get RAID out of the box. It is my understanding that you cannot set up RAID from a normal Ubuntu CD and will need to use either the Server Edition or alternate install CD. Did you use the latter?