Easy BCD overload?

#1
First of all-my sincere thanks to all who maintain Easy BCD and enable us to experiment with various OS in so many diverse ways.
Hard Drive One:Vista 64.
Hard Drive Two:XP 64-installed first here before Vista.
Hard Drive Three:first primary partition -Ubuntu 8.04,followed by an extended partition containing:Xubuntu,Kubuntu-all 8.04 and Ubuntu Studio,all partitions including swap well set out and shown in Gparted.

Can boot so easily via BCD into any of these OS,initially had to rewrite the menu list after installing some of the above because the wrong hard drive was selected by grub even though I designated each partition at advanced install/grub.

Have now followed instuctions on wiki to install Fedora 8 -selected partition to install grub and even given grub a /boot partition.After install returned to Vista and BCD, added the new OS(fedora) in the usual way,rebooted-No sign of the new entry on the Screen! All the other OS are present and correct and the new system partitions are correct in Gparted.
Have tried this three times in case I made a mistake at install-no luck.
Too many OS for BCD?
The other problem is I cannot install Debian after many attempts-it tries always to install grub to the MBR rather than the partition I have selected for it-I would welcome any advice.Thank you,John
 

mqudsi

Mostly Harmless
Staff member
#2
Hi John,

It seems there's a conflict with EasyBCD on certain configurations w/ current builds of Vista and the BCD registry - EasyBCD 2.0 (almost done!) addresses them all.

If you'll check the "Detailed" output of EasyBCD, you'll find that the Fedora entry most likely doesn't have a "device" parameter, or it has one set to the wrong drive.

Go to the "Change Settings" page, select Fedora from that list, and change the drive letter to C:\
 
#3
Guru-very many thanks for your reply.
In Detailed Mode:Vista OS device partition =C (the only OS on C.)
All the other OS are :device partition=D and they work so well on boot via BCD.
While waiting for your reply I removed fedora and installed Mint Linux which in the past has given no problems at all. In detailed mode it is:device partition= D. Like fedora-it does not appear on the list with the others on the Windows MBR sceen-yet it looks fully installed on the partitions /dev/sda 12 (/ ext 3) and partition 13 for swap-both in the extended partition alongside four other OSs.
I tried Mint on /C-it made no difference!
Regards,John
 

mqudsi

Mostly Harmless
Staff member
#4
Can you please paste the contents of Detailed Mode here? (use a
Code:
 tag, please)
 
#5
Forgive my ignorance-I can select all the text from the detailed mode but am unable to copy it-nothing happens on right click,please advise.
 

mqudsi

Mostly Harmless
Staff member
#6
use ctrl+c or EasyBCD | Diagnostics | Copy Debug Data
 
#7
Easy BCD-overload?

Code:
Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=D:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {f3693cfa-09ce-11dd-9d75-b78e7b405325}
displayorder {f3693cfa-09ce-11dd-9d75-b78e7b405325}
{fe878a4e-f697-11dc-86ac-00038a000015}
{fe878a5d-f697-11dc-86ac-00038a000015}
{fe878a5b-f697-11dc-86ac-00038a000015}
{fe878a5e-f697-11dc-86ac-00038a000015}
{fe878a60-f697-11dc-86ac-00038a000015}
{fe878a65-f697-11dc-86ac-00038a000015}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 300
Windows Boot Loader
-------------------
identifier {f3693cfa-09ce-11dd-9d75-b78e7b405325}
device partition=C:
path \Windows\system32\winload.exe
description MICROSOFT WINDOWS VISTA x 64
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice partition=C:
systemroot \Windows
resumeobject {f3693cfb-09ce-11dd-9d75-b78e7b405325}
nx OptIn
Real-mode Boot Sector
---------------------
identifier {fe878a4e-f697-11dc-86ac-00038a000015}
device partition=D:
path \NTLDR
description MICROSOFT WINDOWS XP PROFESSIONAL x 64
Real-mode Boot Sector
---------------------
identifier {fe878a5d-f697-11dc-86ac-00038a000015}
device partition=D:
path \NST\nst_grub-48F5E7E88265CB577D0C74911405C8ED.mbr
description LINUX UBUNTU 2008
Real-mode Boot Sector
---------------------
identifier {fe878a5b-f697-11dc-86ac-00038a000015}
device partition=D:
path \NST\nst_grub-7B8DE948108BFC500A04DB6871E77CF2.mbr
description LINUX XUBUNTU 2008
Real-mode Boot Sector
---------------------
identifier {fe878a5e-f697-11dc-86ac-00038a000015}
device partition=D:
path \NST\nst_grub-636813743C88B4C0A70B90A131F6D340.mbr
description LINUX KUBUNTU KDE4 2008
Real-mode Boot Sector
---------------------
identifier {fe878a60-f697-11dc-86ac-00038a000015}
device partition=D:
path \NST\nst_grub-8EE7679439372561F1B82D07349A316A.mbr
description LINUX STUDIO 2008
Real-mode Boot Sector
---------------------
identifier {fe878a65-f697-11dc-86ac-00038a000015}
device partition=D:
path \NST\nst_grub-14C5AED3F044AF9C5E43C158F62FFF32.mbr
description LINUX MINT 2008
Thank you,John
 

mqudsi

Mostly Harmless
Staff member
#8
I don't see the Fedora entry in there.........
 
#9
Easy DCD overload.

I think I mentioned that while waiting for your reply-I removed Fedora and installed Mint Linux.The same problem-Mint is on the partitions stated earlier,it is not seen in the list with the other OSs on Windows MBR screen. I have had zero problems with Mint in the past,so it seems that whatever I now install does not show as an entry on my list-after Ubuntu Studio-the last on my list which still boots fine.Regards,John
 
B

BlogApostille

Guest
#10
After mucking around with the:frowning: grub-installer python scripts for a little bit, I finally bit :brows:the bullet and did what you suggested. It worked like a charm :smile: EasyBCD is an excellent piece of software.:??