Easy USB creator checksum failure


I have a laptop that doesn't have a cd/dvd drive so I am trying to use the EasyUSB creator and this is the error I am getting. I know it says to email easyre@neosmart.net for help, but it has been 4 days with no response at all. I was hoping someone here might see this and be able to help me out before this weekend.


  • failure.png
    305.5 KB · Views: 5


Telephone Sanitizer (2nd Class)
Staff member
It seems pretty specific that the problem is a corrupt ISO download, in which case the only option is to try it again.
No idea why the delay on email response.
Unfortunately this is an end-user forum. Even we moderators are just globally spread volunteers with no inside information.


I thought it was a corrupt ISO download as well and have tried it several times in different pc's and browsers but still no luck. I will probably will end up taking it to my friends house this weekend and re-installing windows over again and wishing I never bought this. I can't wait forever for support that might not even solve my problem. Thanks for at least responding back to me though.


I ended up taking my laptop to my friends house and reinstalled windows and got everything set back up. Guess what the first email I get is? Tech support finally responding back after 6 days with a new download link that is useless to me now. The good thing though is that my friend set me up with macrium reflect so that I can image my pc weekly and not have to deal with this again. Having an image is the only real guaranteed way to get your computer backup and running in minutes. I just wish I would have learned about that before this happened.


Staff member
Glad you are OK. Sometimes the owner is away hence the delay. Often the download he includes is one version higher than what's shown on the web pages as he is constantly testing newer versions. That often helps a situation.
Anyway, all's well that ends well.
Good luck :wink: