EasyBCD 1.5.2474.40530 UI Freezes

Ex_Brit

Moderator
Staff member
What process would cause the UI to freeze? I can click maybe one button and then no more. I've been getting the same problem with the UI of my backup software..EMC Retrospect Express HD and am wondering if McAfee file protection has something to do with it, or maybe some recent MSFT update.
Everything worked fine on both these UI's until recently.

Has anyone else experienced this?

OK guys...solve the mystery!
 

mqudsi

Mostly Harmless
Staff member
EasyBCD's GUI is built with the .NET 2.0 Framework.

Did you recently install any programs that insisted on installing their own copy of this Framework?
 

mqudsi

Mostly Harmless
Staff member
BTW, I guess if this happens to other apps on your PC its really not an EasyBCD bug... but I'll wait for more info before moving the thread.
 

Ex_Brit

Moderator
Staff member
I do have .net 2.0 installed. I actually installed .net 3 but removed it after realising that it was totally unnecessary. I wonder if there's a way to repair the .net installation?

I managed to get the other UI sort of working...still not perfect.
 

mqudsi

Mostly Harmless
Staff member
Is this Vista or XP?
Did these problems exist before installing and uninstalling the 3.0 Framework? I think by uninstalling 3.0 part of 2.0 was corrupted.

If you're on Vista, 2.0 shouldn't be installed. If you're on XP, download the 2.0 installer again, and re-run it.
 

Ex_Brit

Moderator
Staff member
This is on XP. What I've done is go to Add or Remove and removed all the .net components in the reverse order that they were installed, then I went to Updates (after a reboot) and reinstalled all of them.
It still seems intermittently "sticky". The interface will work fine for a few clicks then freeze up. Same with my other software.
I'm wondering if McAfee is affecting it and have left a post in their engineers section, hopefully get an answer early in the week. I'm a MOD there and know that the latest updates have caused havoc with some systems.
 

mqudsi

Mostly Harmless
Staff member
Interesting. Any error messages in Control Panel | Administrative Tools | Event Viewer | Applications or System?

I'd try running in Safe Mode and seeing if the problem still presents itself...
(oh, and switch to NOD32, you'll never go back! :tongueout:)
 

Ex_Brit

Moderator
Staff member
Nothing in event viewer except when I first tried in plain Safe Mode, Easy BCD refused to open. In Safe Mode with Networking, however, it did open and every button worked without hesitation.
Back to normal mode and the buttons work, seemingly, when they feel like it only.
I still think something else is interfering with this.
I agree regarding NOD32, but as McAfee gives me all the protection I need for free as long as I work their forum, I really have no choice right now.
 

mqudsi

Mostly Harmless
Staff member
I think that concretes it - it's definitely a non-Framework 2.0, non-EasyBCD-specific issue.

Try disabling McAffee's service and startup entries (most effective way is via msconfig.exe)?

Thread moved to Windows Support
 

Ex_Brit

Moderator
Staff member
Thanks for moving it..yes it's now a Windows issue. I tried the msconfig approach - got errors that certain elements needed Admin status to disable..I am the Admin, so then proceeded to completely uninstall all McAfee, even used their "MCPR" tool which removes all vestiges from the registry. Rebooted and unfortunately..it isn't McAfee that is causing this. Both EasyBCD and Retrospect UI's still are acting up.
It's has got to be either a recent Microsoft update or some other software I'm using....but who knows what that is!!
 

mqudsi

Mostly Harmless
Staff member
I doubt it's an MSFT update - because if it was, it would still happen in Safe Mode.
Anyway, good thing McAfee wasn't to blame!
 

Ex_Brit

Moderator
Staff member
Thanks CG. I've also posted on the MSFT NG's XP Help & Support. It's a mystery. I guess I'll just have to get used to clicking 1 button, minimising/maximising between every subsequent click!!
 

mqudsi

Mostly Harmless
Staff member
That fixes it?

Aren't you having a lot of problems with your current setup?
(*cough* Format *cough*)
 

mqudsi

Mostly Harmless
Staff member
ouch.

previously it was the ATi drivers causing trouble, no?
Just a wild thought, but uninstall the drivers and use the stock XP ones (that suck). Does that fix it?

If yes, there's alternate (and better) drivers you can use.
 

mqudsi

Mostly Harmless
Staff member
OK, nothing for it now but to disable startup entries and re-enable them one-by-one to see what causes the problem..
Boy, I do *not* wish to be in your place right now! :frowning: :openmouth:
 
Top