EasyBCD 1.7.1 doesn't find OS X Leopard partition

#1
as title says EasyBCD 1.7.1 doesn't find Leopard partition.
This is what i did:
i took a notebook Hp dv6000 with Vista Premium installed.
I created a partition for OSX.
Now i have 3 partition: C (Vista); D (recovery); E (OSX).
I installed Leopard correctly (no errors found), at the end it asks to restart so i did it but at startup was loaded vista and not leopard. I launched EasyBCD 1.7.1, it recognized only vista OS, i did as documentation says, so i reinstalled the vista bootloader, i tried to add OSX entry, but if i go on "Mac" tab i can't find "Auto-configure Mac Settings". I select "Generic x86 PC, i change the name and check "Add Entry". If i go on "View Settings" tab, BCD shows 2 entries: Vista and Leopard. But Leopard has got drive "C" like Vista... if i try to change it i can choose only between C (Vista); D (recovery); Boot.
i tried also launching Leopard installation and doing a new darwin bootloader installation on osx partition but nothing changed.
I hope someone could help me and sorry for my awful english
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
I installed Leopard correctly (no errors found), at the end it asks to restart so i did it but at startup was loaded vista and not leopard.
I think this is where the problem is. Leopard should have loaded right away not Vista. Since Vista loaded that means the OS X Darwin loader did work.
 
#3
i know it but if i try starting with -v on screen appears only hd31,1 (dvd-rw drive) option. so what could it be? or better... what could i do? :tongueout: thanks a lot
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#4
Well Sadly here at NeoSmart we cant support OS X and the issues it has.

Mac OS X - NeoSmart Technologies Wiki

Since it wasnt made for the PC we cant help you get it booting. Maybe Guru has some other ideas. But your best bet it to find a forum that can help you get Darwin loaded.
 

mqudsi

Mostly Harmless
Staff member
#5
What happens when you pick the entry that EasyBCD created for OS X? (it should say drive C:\)
 
#6
if i add osX entry, EasyBCD sets it up as C:\... anyway i tryed a lot of solutions, also the chain0 one but nothing changed. Never restarted on Leopard, the loader seems to recognize only vista partition. at start up if i choose to load osx i have a black screen with a phrase (i don't remember know the right words cause i formatted the osx partition, anyway the meaning was something like "nothing to load".
 

mqudsi

Mostly Harmless
Staff member
#7
It can't be anything but C:\ because that is your boot drive and the drive that EasyBCD stores its boot files on.

If it doesn't load that means that the method of installation you used did not properly set up your bootsector with the Darwin bootloader. A proper OS X installation will do that - which means that you'll need to get that fixed first.
 
#8
wow that messed me up for so long... it HAS TO be c:\

also if that still doesn't work set your os x partition as active using your favorite partitioning program

that will tell you if your install went ok at least
 
Last edited: