easyBCD 2.0 help

#1
I am using easyBCD 2.0.76 to remove vista from a vista win7 dual boot. I have done t he following steps:
boot in w7
run bcd
diagnostics, change boot drive to C: from D:
rescue my system
reboot , bios, change win7 to be boot drive
restart win7, adm tools, comp management, disk mang, delete vista column

when i try to delete or format the vista HD i get message that "windows cannot delete the active system partition on this disk"

same for format basically

what am i missing here?
 

Terry60

Knows where his towel is.
Staff member
#2
Hi large, welcome to NST.
Can you post a DM screenshot of your config as detailed at the end of the sticky
 

Terry60

Knows where his towel is.
Staff member
#4
Your problem is that W7 is installed in a logical drive.
Logical drives cannot be "active", so they cannot contain the boot files.
Even if you copy them there, they won't (can't) be used to boot with.
Vista is still "system". That's still where W7 is booting from.
If you want the boot files to be used from W7 you'll either have to reinstall it into a primary partition or use a 3rd party partition manager capable of converting logical to primary on the fly.

Addendum:

Alternatively, you could format that little unallocated space as a primary and "change boot drive" to that one.
 
Last edited:
#5
Thanks. I did not have the nerve to make the logical c: drive a primary, although the software i used would do so, but i did make the small 1.29 GB partition a primary with it and used easyBCD to put the boot stufff on it. all worked gtreat and boots into win 7 with a formated ex-vista HD.
btw- the software that i used was this "FREE HOME edition"

Partition Wizard Home Edition

in case you have my question in the future.
 
#6
Hi, I have a major problem getting EasyBCD 8.0 to recognize Grub2 on a secondary drive. Unfortunately I cannot get Windows to assign a letter to said drive since installing Ubuntu 9.10 on it. Trying to create a dual boot windows/Ubuntu system. Any advice would be greatly appreciated.

wasitchu

Addendum:

Sorry, that was supposed to be EasyBCD 2.0 Build80.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#7
You can't assign letters to Linux drives. They use different filesystems.
 
#8
I was just able to get build 82, could not before for some reason. So far, it still does not see any drive letter for the external drive with Ubuntu on it, nor will it recognize grub2 on the drive I have Ubuntu on.

wasitchu

Addendum:

Thank you computer Guru, what options do I have to get this to boot dually from C and the drive that Ubuntu is on?

wasitchu?
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#9
Just delete the Linux entry from the BCD, add it again selecting grub2 from the dropdown.
Easy2 will find it and configure it automatically.
You don't need to (and can't) give it a letter for the reason CG gave. Windows doesn't assign letters to disk space formatted with a file system it doesn't recognize.
 
#10
Thank you Terry, will try that.

wasitchu.

Addendum:

I deleted entry, and just added a grub2 type, went to add entry, and EBCD came back "Legacy grub" then booted me into a sub-directory called grub, from which I could do nothing. Had to reboot into windows.

wasitchu

Addendum:

My settings look like as follows:

There are a total of 2 entries listed in the bootloader.

Default: Windows 7
Timeout: 30 seconds.
Boot Drive: C:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Ubuntu
BCD ID: {d653c064-c9f3-11de-916d-0024e8070f33}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub0.mbr


however, the Ubuntu is on drive 17 partition 1

Addendum:

I am thinking of just deleting the whole linux installation and using 8.04 instead as I have read that EasyBCD has no problem locating and using the original Grub, but I then found the Neogrub, though I am not sure how to use it, started wondering if that would help me. I am really confused here.

wasitchu
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#11
select grub2 (below legacy grub) from the dropdown and make sure it's visible in the window when you click "add". (careful that nudging the scroll wheel doesn't change the dropdown value)
 
#12
I did just that Terry, then, after I hit add, a few seconds went by, and the window in the menu changed to Grub(legacy). I tried several times, even tried pointing the program to the right drive with the Ubuntu 9.10 installed, but it still comes back this way.

wasitchu
 
#13
Problem solved

I figured out what no one else on here could, because you do not have the same setup that I do. But, I want to thank you all for all of your help. In my case, I had Ubuntu on disc 18, but, when the system initially boots, it only sees the first 4 discs on my system. So, the solution was to move the disc with Ubuntu into position 1. Then run EasyBCD as you have described above. And, it all worked out beautifully. How I figured it all out was solely by accident, but I now have a dual booting system with both Ubuntu and Win7. Thank you all.

wasitchu
 

mqudsi

Mostly Harmless
Staff member
#14
Disk eighteen?!?

:|
 

Terry60

Knows where his towel is.
Staff member
#15
Post a DM screenshot.
I'd like to see that !
 

mqudsi

Mostly Harmless
Staff member
#16
Would they fit in one screenshot even?
 

JustinW

Super Moderator
Staff member
#17
Disk 18? :lol:
Surely its a typo, otherwise no wonder you came here looking for help. I would have trouble managing that many disks at once :smile:
 

mqudsi

Mostly Harmless
Staff member
#18
I don't think it was a typo, because

it only sees the first 4 discs on my system.
But... wow! I have 7 and consider myself to be a super fringe case.... and, yeah, I've never tried to boot from anything past disk 3.