EasyBCD 2.1.2 Helped Ruin My Bootloader

#1
I'll try to make this short and as simple as I can (it is possible that I mixed up a portion of this chronologically, sorry if you find such a discrepency):

I got EasyBCD 2.1.2 a few days ago, and clicked on "Add New Entry" and clicked "Add Entry" after chosing my boot drive, nothing seemed to happen so I repeated the process a second time. I exited the program and it told me something like "If you exit now, you cannot boot up". I simply didn't believe it, and rebooted. Came up with three choices, the first called let's say "Windows 7" and the other two something like "Windows 7 Home 64bit". When I tried to boot from the first one, it would say something like "Incorrect boot device, please insert bootable media" and if I chose the second or third option, it would just silently restart. My BIOS also used to have a boot option called something like "Windows Boot Manager" and was no longer there. I just tried to force a boot from the HDD that I know Windows 7 was installed on, same error message. No matter what I tried it wouldn't boot.

I reinstalled Windows 7. Thought everything would be fine, given I formatted everything and strarted completely fresh. Installed some drivers, tried this and went through the first two options WITH the installation cd and only the second option WITHOUT it and with the EasyBCD program instead and rebooted. Same thing happened, except for the options. It just came up with the "Incorrect boot device, please insert bootable media" message again. I started punching myself in the face, tried to change the boot order around, didn't do anything. Then I put the Windows 7 disc in and forgot to press a button to boot from it, and Windows booted.

So Windows now boots only if the Windows installation disc is inserted, read from initially, but not booted from. Please help me out, this is quite annoying and I'm humbled by how stupid I feel, heh.
 

Terry60

Knows where his towel is.
Staff member
#2
What system were you adding a new entry for ?
How many W7s do you have ?
Which partition is "active" ?
 
#3
1. I don't know what you mean by "system", but I built the computer and am running Windows 7 Home Edition x64 on one HDD.

2. Just one on what when I'm logged into Windows 7 calls drive 'C', but when I boot from the installation cd and inquire, it seems to point to 'D'.

3. In Computer Management, my HDD that Windows 7 is installed on has three partitions, the first is 100 MB NTFS 'System Reserved' and says "System, Active, Primary Partition", the second 78 GB NTFS 'C:' says "Boot, Page File, Crash Dump, Primary Partition", and the third 1789 GB NTFS 'D:' says "Primary Partition".

Hm, does that mean I'd need to change the active partition to the second?

Also, I've been getting random "digital crackle" coming from the tower maybe every fifteen minutes, could it be a defining characteristic of a failing boot sector in a HDD or something?
 

Terry60

Knows where his towel is.
Staff member
#4
EasyBCD is a tool for managing the contents of the BCD. You will only ever come across the BCD as a user if you are multi-booting different OSs on a PC. If you just have a single OS, what "new entry" were you adding.
It's normal for W7 to install its boot files into an unlettered 100Mb partition it names "System Reserved", unless you take measures to prevent it from doing so. That's why it's both "active" and "system"
Disk Management flags have the following meanings


"boot" = "this is the system you're running"
"system" = "this is where I found the boot files for the currently running system"
"active" (on the first HDD in the BIOS boot sequence) = "this is where I started the search for the boot files"
"active" (on subsequent HDDs in the BIOS boot sequence) ="this is where I will look if I don't find something in the MBR on the first HDD"

Please post the contents of EasyBCD "view settings" (detailed mode)
 
#5
I thought I could use it to force a boot choice when I originally had my old IDE HDD with Windows XP on it, because iwhen I plugged it in it wouldn't let me run ANY OS; I thought I could trick it into working somehow, took a shot in the dark. When I did the new entry thing, I didn't actually have the other IDE HDD installed, because I couldn't boot with it installed, and I didn't want to try and hot plug it after I booted from my SATA HDD. I thought I'd force a boot menu, THEN plug in my IDE HDD and try it from there, but it failed miserably. But right now I only have one SATA HDD installed with only one OS, which is Windows 7 Home x64.

Untitled.jpg
 

Terry60

Knows where his towel is.
Staff member
#6
OK. Well your attempt to boot an old XP, if it came from a different PC, was doomed to failure. Each install of any Windows OS is tailored during setup to the existing hardware. Not just the internal "map" of the PC, but the entire driver set (most crucially for the mobo chipset and the graphics adapter) will be wrong for the new hardware (like trying to navigate around England with a map of France (in French !))
At the least, you would need to "repair install" XP from a retail XP CD to fix the hardware configuration issues, and if XP came pre-installed on your previous PC, it will be an OEM copy, with no universal driver set, and a EULA which prohibits its use on any hardware other than that with which it was supplied, so even if you were somehow able to fix it, MS would not validate your attempts to activate it with that serial number.
As to your problem trying to boot W7, the BCD looks fine so I would guess that the problem might be to do with your connecting and disconnecting of the old HDD having upset the BIOS boot sequence.
Enter the BIOS setup
How to access/enter Motherboard BIOS
and check that your W7 HDD is at the top of the HDD boot sequence.
 
#7
I didn't know that about the "fingerprinting" of physical hardware and whatnot when it came to operating systems, thanks for that information. I also do still have my WinXP retail discs, too.

But to be particular, although this has nothing to do with anything anymore because I wiped that old IDE HDD with WinXP on it clean and don't have the drive connected anymore, I wasn't trying to boot its WinXP, I was trying to boot the new SATA HDD with the current Win7, but have access to the information on the old IDE HDD. The old HDD just wasn't letting me boot ANYTHING if I even had it so much as connected to the motherboard. Anyways, now that I have that old IDE in the other room in a box somewhere, it's completely out of the equation now.

And the funny thing about the boot order in the BIOS is that there used to be a choice for a "Windows Boot Manager", and now there isn't; only my SATA HDD with Win7 at location 0, my external USB drive that only have data and no OS on it, and my DVD drive at location 1 are choices I have.

A. What my boot order looked like prior to all this mess was something like this:
1. Windows Boot Manager
2. HDD at 0
3. DVD drive at 1

B. Now it looks like this (only way it will boot):
1. HDD at 0
2. DVD drive at 1

I admit it boots up PERFECT aside from two things:
1. I NEED to have the Win7 disc in the DVD drive at boot up, AND the DVD drive MUST be included in the boot order menu. If I don't it will say:
"Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key"
Also just a small note, when everything is set up to boot Win7 (situation "B" above), right before it does, it will have the message:
"Press any key to boot from disc" (or something close to that)
It's like it's reading something from the DVD that is normally read from the HDD.
2. Ever since this happened I've been hearing "crackling" from what I'm sure is my HDD that lasts for maybe half a second seemingly randomly every twenty minutes or so. NEVER heard this noise before, its a new (one month old) HDD by the way.

I do appreciate the help. I'm reading about commands in Windows' bcedit, bootrec, and bootsect and trying to figure out if I can either fix something or make it worse by messing around with it, heh. I'm an impatient person, I suppose. I mean I swear I looked practically everywhere and my morale is severely being depleted.
 

Terry60

Knows where his towel is.
Staff member
#8
Run EasyBCD > BCD Deployment > "Install Vista/7 boot loader" > Write MBR
and try booting without the DVD.
 
#9
Tried and didn't work, same exact thing.

What if I install Ubuntu, let's say, then before installing Win7 again, make sure I format everything, Ubuntu included? Could that refresh something or would that be a silly idea that has no merit or substance?

And a reminder, I tried everything at this point on THIS website.
 

Terry60

Knows where his towel is.
Staff member
#10
Post a screenshot of your Disk Management please (making sure that all devices and their flags are visible).
The sticky will help if you need it.
 
#11
Some updates first (Disc Management screenshot below) :
I did change the active partition from the system reserved F: to the boot located C:, although this didn't seem to change anything either way, I do now see the F: drive sitting in "My Computer", which I've never seen before, other than that, nil has changed, it seems. If you think the situation described below wouldn't have happened have I kept the active partition as the system reserved, I'll try installing Ubuntu again on this drive after I change it back to see.

I also installed Ubuntu 10.10 on my old IDE that I was originally trying to get data off of. Interesting story: I unplugged my SATA with Win7 and put the IDE via a IDE to SATA apapter and booted up with the Ubunto disc in. (Insert *** below) Formatted and installed Ubuntu on a single partition. Played around a bit to install graphics drivers, then rebooted. SAME thing, even with THIS drive!?! Ok, so I thought to myself since I'm in the twilight zone and nothing is making sense to me anymore and I'm beginning to question everything I think I know about computers, why not take out the Ubuntu disc, and boot up with the Win7 disc instead, just like the SATA drive with Win7 on it, and see if it'll boot then, just for the heck of it.

(***
When I first attempted to install Ubuntu, I used my SATA HDD that has Win7 installed on it. I was just going to format everything and start fresh with Ubuntu, then reinstall Win7 and see what would happen. This is the error message that came up:
/dev/sda contains GPT signatures, indicating that it has a GPT table. However, it does not have a valid fake msdos partition table, as it should. Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partition tables. Or perhaps you deleted the GPT table, and are now using an msdos partition table. Is this a GPT partition table? Yes or No?
No matter what I answered, it would hang indefinately, so I then ditched that idea and installed it on the IDE HDD.)

It worked!?! Why the F#*@ would I only be able to boot UBUNTU, that's on a COMPLETELY SEPERATE HDD THAN WIN7 which isn't even connected to the computer mind you, unless a Win7 install disc is in the DVD drive?!? Please hire someone to snipe me. Sm I going to have to clear the CMOS or just dump water on the motherboard or something?
--------------------------------
Untitled.jpg
 

Terry60

Knows where his towel is.
Staff member
#12
Can you check in the root of C and F whether they both have bootmgr and a \boot folder (you'll need folder options like this to see the super-hidden files)
 

Terry60

Knows where his towel is.
Staff member
#14
Use EasyBCD > Files > select BCD store to list contents of both "view settings"
 

Terry60

Knows where his towel is.
Staff member
#16
I'm getting "invalid attachment".
Just copy/paste the text.
 
#17
Again, this is the one in F:

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=F:
path \bootmgr
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {de080419-69ab-11e1-8378-c3cd3556b28e}
resumeobject {1f8184a2-14de-11df-9734-f08c6d8c50b0}
displayorder {de080419-69ab-11e1-8378-c3cd3556b28e}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 10
displaybootmenu No
Windows Boot Loader
-------------------
identifier {de080419-69ab-11e1-8378-c3cd3556b28e}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7 Home Premium (recovered)
locale en-US
recoverysequence {de08041a-69ab-11e1-8378-c3cd3556b28e}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {d154259e-6992-11e1-a6d7-806e6f6e6963}
 

Terry60

Knows where his towel is.
Staff member
#18
Both BCDs reflect the proper disposition of your PC with F active (F for bootmgr and BCD, C for W7) so with a proper W7 MBR, (which you said you wrote in a previous post) and F active, the PC should boot normally.
It's not a UEFI PC is it ?
 
#19
You didn't need the 'BCD' from C: to look at? That doens't change anything? I did go back and make F: the active volume just now, because you made it seem like F: should be. So would I be able to access the 'BCD' in C: now?

so with a proper W7 MBR, (which you said you wrote in a previous post)
Just to ensure that this is the case, it can't hurt to re-write it, right? Which subsection of the link I posted tells me how to do that; I'll do it again just to make sure. I mean, I may have done a whole bunch of random crap on those pages to haphazardly try to fix it. So maybe you could mention what exactly I should do from this point on to ensure the Win7 MBR is written properly?

I stated this before, but I'll mention it again because maybe it goes hand in hand with something. Every once in a while I'll get a loud "beeping" or "crackling" coming from what I now know is my HDD. I know it is my HDD due to every time I hear it now I catch the HDD activity light blinking. Could this mean something? It definitely started happening after this whole mess happened.

And yes, it has a UEFI BIOS.

Addendum:

I rebooted as F: active, and it allowed access to the bootmgr on C:. Loaded that BCD into EasyBCD and here's what it says:

Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device boot
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {334cd731-6a6e-11e1-bc14-5404a64b79d2}
resumeobject {1f8184a2-14de-11df-9734-f08c6d8c50b0}
displayorder {334cd731-6a6e-11e1-bc14-5404a64b79d2}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 10
Windows Boot Loader
-------------------
identifier {334cd731-6a6e-11e1-bc14-5404a64b79d2}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows 7
locale en-US
osdevice partition=C:
systemroot \Windows
resumeobject {a03dd4bd-6af5-11e1-bb12-806e6f6e6963}

What's up with the BCD from F: saying "displaybootmenu No"?
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#20
I was assuming I'd already seen your C BCD in post #5, but I now see that's a 3rd version ?
Write MBR was in post #8

I'll leave it to CG to comment whether the UEFI could be the problem, and what to do if it is.