EasyBCD boots directly to Linux, can't get into Windows 7

#1
So yesterday I went ahead and installed EasyBCD in Windows 7 64-bit and added my Slackware Linux partition to the menu, which uses LiLo. I have Slackware as the default boot. Now when I boot up the computer I see the EasyBCD modified boot screen for just a flash before it goes into the LiLo menu, never giving me a chance to even select Windows. I believe there was an option in EasyBCD to let me select the time it waits for a selection and that the default is 0, which I may have forgotten to change. Any suggestions on how to fix this if I can't get into Windows?
 

Terry60

Knows where his towel is.
Staff member
#2
The default isn't 0 (that would be very silly), but EasyBCD will let you set it to 0 or tick the "don't display" box, both of which are very unwise unless Windows is the default system.
Can you F8 as you power-up, to access the W7 extended boot menu, then use safe mode to run EasyBCD and set the options to friendlier values.
 
#3
Really? So those are NEVER set to 0 unless specified? I was pretty sure right after installing EasyBCD that I proceeded to add the Linux partition, set that as default and then move the Linux entry up so that it's above the Windows one. After saving and rebooting, I could no longer get that boot menu to even select Windows. I will try the F8 option tonight when I get home...
 

JustinW

Super Moderator
Staff member
#4
Defaults 30 seconds. If you set the skip boot menu or timeout to 0, a Windows system should always be the default entry. To fix this boot from our recovery disc > Repair my computer > select your system > next > command prompt:

bcdedit /set {bootmgr} timeout 30

Restart the computer. You'll have 30 seconds to select a Windows entry. Once in Windows put back the Windows entry as the default.
 
Last edited: