EasyBCD "Cannot find file specified" from one partion

#1
Hi all,

I have a problem similar to that in many existing threads but cannot find a solution or explanation to my specific problem. It's a bit of a long story but i will be as brief as possible...

I installed Win7 on 2 primary partitions on one physical drive. Windows Bootloader kicked in after the second install as expected. I then installed Easy BCD on partition 1, the first OS installed, and made some changes such as default OS and OS Names ("Default OS" and "Test OS"), all was good.

I then realised that when my laptop is docked via a USB docking station to my secondary monitor and other devices i could not access the boot menu as my second monitor does not output until windows drivers are loaded, my secondary monitor comes on at the windows login screen. So to save undocking each time i want to switch OS's i also installed EasyBCD on partition 2, the second OS installed, and when i want to use this OS i changed the default OS using EasyBCD on partition 1 then reboot. When i want to change back i used EasyBCD on partition 2 to change the default back again and reboot. EasyBCD on both partitions reported and applied changes to the Windows Bootloader successfully.

I then installed various drivers and app's and changed various system settings in the OS on partition 1 and instead of doing all this twice created an image of partition 1 using Paragon Backup and Recovery 2011 and then restored that image to partition 2. After cloning partition 1 to partition 2 i did have to use Windows Repair on my Win7 disk to rebuild the bootloader, i'm not sure why, but once this was done the bootloader worked fine again but EasyBCD on partition 1 stopped working reporting "Cannot find file specified" while EasyBCD on partition 2 worked fine.

In frustration i have also uninstalled EasyBCD from both partitions and reinstalled it on Partition 1 only. I have browsed to Program files/NeoSmart/EasyBCD/profiles/Neosmart.bcd which has enabled EasyBCD, but the summary reports:

There are a total of 0 entries listed in the bootloader.
Default: Not set
Timeout: 0 seconds
EasyBCD Boot Device: \

That's where i'm at now. As i say i can choose OS at the Winodws Bootloader, I can use EasyBCD on partition 2 (although i've now uninstalled it) to apply changes to Windows Bootloader but not using EasyBCD on partition 1 which doesn't seem to be linking with the Windows Bootloader at all.

Sorry for the lengthy post, hope someone can help!

Thanks in advance.

Addendum:

Just to update, after reading another post i have found that by assigning a drive letter to the System Reserved partition EasyBCD on partition 1 now finds the BCD file automatically. If i remove the drive letter the error returns.

I don't really want this drive to be visible in My Computer and i don't understand why EasyBCD on partition 2 finds the BCD without needing to assign a drive letter to the System Reserved partition, so any help in this regard would be very much appreciated.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
post a screenshot of Disk Management from each of the W7s, with all of the partition status flags visible.
(How to in the sticky if needed)
 
#3
I have attached the screenshots...

As i hope you can see, i have had to specify a drive letter (Z) to the system reserved partition when using C: System, but not when using D: Test OS, which is shown as C: drive when i boot into it.

Thanks.
 

Attachments

mqudsi

Mostly Harmless
Staff member
#4
Terry, I'm not seeing it. Do you have any idea why?
 

Terry60

Knows where his towel is.
Staff member
#5
It all looks fine superficially.
Your assertion that you needed "startup repair" after cloning, leads me to suspect that at some point the BCD was in C, not in the "Sys Res" partition, and that you cloned it to D (which would require repair).
However EasyBCD should still find the "active" BCD , letter or no letter, unless you are making use of its latest feature, the ability to force it to start using a BCD other than the one on the active partition.
Can you check whether you do have redundant copies of the \boot folder on each of your systems, and whether you have the auto-load box ticked in EasyBCD tools/options. (you'll need folder options like this to see super-hidden boot files)
 

mqudsi

Mostly Harmless
Staff member
#6
Oh, right. I forgot about that feature!
 
#7
Sorry i have not posted sooner, i've been real busy and this problem was put on the back burner!

I don't believe i am using the "force" option you mention, i've attached a screenshot of the BCD options page (C drive - partition 1). I have only one copy of the boot folder in each Win7 installation.

Thanks again for your help guys!
 

Attachments

mqudsi

Mostly Harmless
Staff member
#8
You shouldn't have one copy of the boot folder on each Windows 7 drive - you should only have one copy total.
 
#9
Right, In each partition i have Windows/Boot containing the following folders:

DVD, EFI, Fonts, PCAT

I'm guessing by the contents this is not the folder you meant?
 

Terry60

Knows where his towel is.
Staff member
#10
It's not in \Windows\boot, just in \boot and you can't see it (super hidden) except like this
 
#11
Hi,

Sorry again for late reply...

I have 2 boot folders as you decribe. One in System Reserved partition and one in C:/ system (my default OS drvice).
 

mqudsi

Mostly Harmless
Staff member
#12
You need to select the one in the \boot\ folder.
 
#13
Thanks, I can't see how to do this in easyBCD. Could you give me instructions please?

Also do i need to do anything with the copy of /Boot folder in the System Reserved partition?

Cheers,
 

Terry60

Knows where his towel is.
Staff member
#14
Going back to my post #5
I've noticed that on my system where I use the "force" feature because my BCD isn't on the active partition, although it works every time the tick is no longer present
(NOTE TO CG - BUG !!)
On your post 7, the same symptoms are exhibited. Although the tick is absent, I suspect you are still navigating to the wrong BCD specified in the box.
Try ticking the box, clearing the field and unticking it.
 

mqudsi

Mostly Harmless
Staff member
#15
Terry, I'm not sure I follow?

Are you saying the box isn't ticked but that the auto-select BCD behavior is still happening?
 

Terry60

Knows where his towel is.
Staff member
#16
Yes CG.
I've done some tests.
If you navigate to a BCD because there isn't one on "active", it will continue to use that one by default even if you don't tick the box to ask it to.
Ticking the box, clearing the field and unticking it reactivates the "Easy can't find..." dialogue, and I'm hoping will cure s1desh0w's problem and go back to the "active" BCD if there is one.
At the same time the "Expert Mode" box becomes ticked unbidden, so I suspect you've got the two functions with wires crossed.
 

Attachments

mqudsi

Mostly Harmless
Staff member
#17
At the same time the "Expert Mode" box becomes ticked unbidden, so I suspect you've got the two functions with wires crossed.
That does sound like something I would do.. Should help immensely in finding it quickly! Thanks.