EasyBCD doesn't apply modification

#1
Hello,
I have got the last version of EasyBCD.
I would like to create a dual boot for :
windows 7 (C:\ in SATA)
windows XP (G:\ in IDE)

By default, my default system is Windows 7.

I have installed win XP without problem (the sata hardrive was unplugged).

(I have replugged my sata drive)
When I open EasyBCD in Windows 7, I see the dual boot :
by default : windows 7
I have sucessfully changed the name of my Windows XP.
And now, I would like increase the default delay because 2 seconds are not enought to choose the WinXP startup.
My problem begins here :
I change the delay : 2s -> 5s
I press : settings saved
Then I go to the menu : BCD deployment
I click on 'Write MBR'
No problem.

I quit and restart easybcd and my settings are correct (5seconds are applied).
I reboot and I have no time to choose the Windows XP startup.
I have just the time to see the name of my changed Windows XP (like I have done in easybcd ; this action works fine).
But the delay of 5 seconds are not applied.

When I reboot with Win7, I restart easybcd, and I see that the delay of 2 seconds is applied (and not my modified one (5s)).

I restart several times, and just one time, I success to choose Windows XP startup... (to be very very quick).

So who could help me ?
What is wrong in my manipulation ?

Thx a lot!
 

Terry60

Knows where his towel is.
Staff member
#2
Don't "write MBR".
That is only ever needed if your Vista/7/8 MBR has been destroyed by Installing XP or Linux on top of it.
By using that, you are undoing what changes you just made in an infinite loop.
Just "Edit Boot Menu" > "Save settings" is sufficient.
btw. 2 seconds should be plenty of time. All you need to do is click one of the up/down arrow keys within that 2 second window and the clock will stop, giving you as much time as you want to pick an option.
EasyBCD Basics - EasyBCD - NeoSmart Technologies Wiki
 
Last edited:
#3
Hello Terry,
you are totally right. Now it works without 'write MBR'. :tongueout:

Regarding the delay, I have to increase it because my computer is an old one ; so the 2 firtst seconds are 'hidden'.

Any way, I thank you a lot for your tip.
Patrick.