EasyBCD doesn't recognize .NET framework

#1
First words, a big thank you to NeoSmart for making this amazing software. EasyBCD really saved me from tons of trouble!
I want to report this issue I met with today: I just reinstalled windows and hence reinstalled EasyBCD. When I run it it says failed to initialize (or something alike), I searched on Google and found that I didn't have a .NET framework. I go to the Microsoft site and downloaded the .NET framework latest version (4.0), and EasyBCD still fail to recognize the framework (it says unable to find a version of the framework). Of course I have installed the 2.0 version and I can use EasyBCD now, I only want to report this issue to you, so that you may want to fix it soon.
Again, thank you very much.
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#2
Different applications require different versions of .net. I have all versions installed for that very reason.
Per 'System requirements' for EasyBCD......
Microsoft .NET 2.0+ Framework. (download here.
Or x64 version here.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#3
Hi darklordnd,

This isn't an issue with EasyBCD.

Microsoft made the .NET Frameworks 1.0 - 3.5 backwards compatible, but 4.0 is something completely different. EasyBCD is written in .NET 2.0, so anything from 2.0 to 3.5 will work.

Addendum:

.... and Peter beat me to it :smile:
 
Last edited:

Ex_Brit

If you're going through hell, keep going.
Staff member
#4
Actually I wasn't sure about the backwards compatibility bit especially with 4 so never mentioned it, thanks CG. I have 3.5 and 4 installed for various applications. I guess I don't really need 2 in that case, but when I reinstalled Vista I noticed that 2.0 wasn't showing up so I went to manually install 2.0 and it told me that I didn't need it, so I guess 3.5 which I had just installed takes care of it.
 

mqudsi

Mostly Harmless
Staff member
#5
Yeah, and Windows 7 ships with 3.5 so you'd only need to install 4.0
 

Ex_Brit

If you're going through hell, keep going.
Staff member
#6
Right, thanks. :wink:
 
#7
Newest Window7 ships with .net 4

Yeah, and Windows 7 ships with 3.5 so you'd only need to install 4.0
...that is what I encountered with my 3 weeks old Win7 Home Premium edition. easy BCD installed anyway, but I cannot find any entry from .net 2.0 or 3.5 in the systems control.

On the other hand I had the problem described in this thread with another XP installation. That was the reason to contact this thread.

- Dieter -
 

mqudsi

Mostly Harmless
Staff member
#8
Well, I hope this clears everything up.

I'm moving this to Windows Support.