EasyBCD dual-booting Vista with Mint -some small problem - (SOLVED)

#1
I've been re-arranging my Windows Vista based pc a bit and have created new free space for a dual boot installation of Linux Mint 9 - KDE (release of July 2010).

My current partition set-up is:

/dev/sda1 NTFS 6.5 GiB (OEM Windows Vista)
/def/sda2 NTFS 80 GiB (Windows Vista)
/def/sda3 Ext4 30 GiB (Linux Mint)
/dev/sda5 Swap 2 GiB

While installing Linux Mint from the live CD I encountered the problem it wouldn't install using all free unallocated space for Ext4 it would only use 18 GiB for Mint and 1 GiB for Swap, so I used advanced settings to achieve settings as above.
But this caused that Mint wouldn't automatically create the dual boot with Vista during installation.
I had red the warning on EasyBCD that Ubuntu 10.4 has a problem using the advanced settings but hoped that would not also be the case with Linux Mint - KDE (although Mint is based on Ubuntu, I know).

I tried to create the dual boot with EasyBCD as follows:

0) Install Linux Mint
1) Add new entry > LinuxBCD > Grub2 > Name: Linux Mint > Add entry
2) Bootloader setup > Install the Vista/7 bootloader to the MBR > Write MBR

When I reboot my pc I will get the option to select either Vista or Mint, and Vista will load correctly, but choosing Mint it will not load Mint.

EasyBCD settings overview:

There are a total of 2 entries listed in the bootloader.

Default: Windows Vista
Timeout: 8 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Linux Mint
BCD ID: {0a733263-8cd8-11hf-a9c8-f754d614kb14}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub0.mbr

Notice that the entry 2 says that Mint is on drive C:\ but it's not, it's actually on drive L (sda3 = L)

Is there something I missed or did I make a mistake somewhere ?
Can I fix this or do I need to re-install Mint, in a different way ?

Thanks for any help you can give me.

[I use EasyBCD v. 2.0.2.117]


Addendum:


Update:

I though it best to go over the settings in EasyBCD again and re-write to MBR.
After re-booting I got the screen with the option to boot into Windows Vista or Linux Mint.
When selecting Linux Mint I got the following screen message:

Windows Boot Manager

Windows failed to start. A recent hardware or software change might be the cause.

And then:

File: \NST\AutoNeoGrub0.mbr
Status: 0x0000001
Info: The selected entry could not be loaded because the application is missing or corrupt.

Press Enter to continue

Then I pressed Enter and got back to the boot selection screen I could select both OS's again and selected Windows Vista, which loaded correctly.

Any thoughts what might be happening here ?
 
Last edited by a moderator:

Terry60

Knows where his towel is.
Staff member
#2
Did you change the Linux entry from C ?
The entry does not point to the Linux partition. It points to the partition holding the NST folder.
The information in there locates Linux.
 
#3
It intrigues me that it appears like I can't assign a letter to the Linux Mint (sda3) partition. After rebooting the assigned letter will have disappeared. Before the installation of Mint I have used Paragon Partition Manager (PPM) to create unallocated space for the Linux installation by shrinking the partition space for Vista.
First I had installed Kubuntu on it, but I couldn't get that to work properly on my system, so I decided to delete the partition to start fresh with a Mint install. (Mint comes with drivers included that are proprietary and are required for my pc to have the basics covered)
When I tried to install Mint in the conventional way (on largest unallocated available space) from the live cd it wouldn't recognize the 'largest unallocated available space' to install on. I then went back and used PPM to create a partition and format it into NTFS. This the live cd recognized, and allowed me to install the Linux (which formated the space to ext4 and a swap2). I tried to assign a letter to it again but only PPM. would recognize the name and letter of the partition, the other partition managers wouldn't. Those other partition managers (EASEUS Partition Master, Partition Assistant Home Edition and Partition Wizard) also couldn't recognize that the Mint partition is in Ext4, but did recognize the Swat2 partition correctly.

So yeah, I am pretty lost right now...:??
 

Terry60

Knows where his towel is.
Staff member
#4
If you want to identify a partition uniquely, you must use the Volume Label.
This is written directly on the disk surface (11 upper case characters for FAT, 32 mixed case for NTFS), and will appear in any OS which can read the filesystem.
Windows Partition Letters are not physically associated with the partition at all. They are "virtual" labels, entirely figments of the imagination of the OS (entries in its registry), and Windows only assigns a letter to a partition it can use (i.e a recognized filesystem, or an empty space).
If you create an unrecognized filesystem (e.g. for Linux), there is no letter assigned for it.
Linux does not use the concept of partition letters at all, and each individual Windows system in a multi-boot will keep its own list of letters, which need bear no relation to the letters which the other systems use. For example, every independently installed Windows will think of itself as C: and obviously can't see the other OSs as the same letter.
A partition manager (or EasyBCD) running inside an OS, will use the partition letters as seen by the running OS. A bootable partition manager, if it uses partition letters, would have no relevance to the subsequent use of those partitions in an OS.
 
#5
Thanks for your help and for bearing with me !

Since I'm a quite determined person I have re-installed Mint.
This time I wrote everything I saw on screen down so I would be able to trace anything down that might go wrong, and to be able to compare it with the configuration of the previous Mint installation.

And I discovered that in the new situation the Mint partition is a Logical partition and in the first install the Mint partition was a Primary partition.
This time after applying EasyBCD I was able to boot in Vista (and it loaded correctly) and I was able to boot into Mint (and it loaded correctly).

So I am assuming that this is all that was to it. I am happy. Now to get Mint to work the way it should... but thats not an EasyBCD matter.

I will mark this thread 'solved', and again thanks for helping out and bearing with me! :smile:

[edit: I can't mark the thread title with SOLVED so admin please do this for me]
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
Congratulations, but I'm not quite sure that's the reason. If anything, Primary would work when Logical doesn't..... but the other way around?
 
#7
I know I know. But dual-boot with Easy BCd is working which is most important, and I won't be able to find a better reason. Could also be the Mint install was corrupted and reinstalling it solved it. I won't bother you with internal Mint problems though :wink: Nuff said.
 

mqudsi

Mostly Harmless
Staff member
#8
Oh well. All's well that ends well.
:smile: