EasyBCD fails to set correct device letter

#1
This is the situation I have Windows 7 in drive C: and XP in F: I need to add the entry for XP.
I set F as drive letter for XP and added the entry.. the problem is easybcd sets the device as C: instead of F: so the new entry is shown at boot but it search for XP in C: where W7 resides. How can I solve this situation?
 
#2
Hello Chris, welcome to NST.
EasyBCD pointed at the correct partition. You do not point it at the partition that contains XP, but rather the "system" and "active" partition (seen in Disk Management) which contains (or is supposed to) the boot files XP needs in order to boot. Though these are sometimes the same, it doesn't have to be. So what you need to do, is with the XP entry in the BCD still pointed at C:, copy over boot.ini, ntldr, and ntdetect.com into the root of that partition, and use [thread=642]2.0 beta[/thread] of EasyBCD to autoconfigure boot.ini for you, so you wont have to if its not configured right. Just go to the Tools menu of the beta, and select "Auto-configure boot.ini".
And then XP should boot.

Jake
 
#4
You will need to go into your Folder Options in the Control Panel, and select to unhide protected system files, and show hidden files and folders, and then you will be able to see them.
 
#5
I found the files.. however when I press yes to autoconfigure boot.ini the program hangs

Addendum:

You will need to go into your Folder Options in the Control Panel, and select to unhide protected system files, and show hidden files and folders, and then you will be able to see them.
Yes I knew that.. I had to copy the files from the system.. anyway I think now I succeeded.. thanks.
 
Last edited:
#6
Make sure you copy the files into the "system" and "active" partition (as seen from Disk Management). I don't know why EasyBCD is hanging. If you're unable to do the autoconfig, then post a screenshot of Disk Management, along with the output of the following command run from EasyBCD's Power Console (on the "Useful Utilities" page):
Code:
bootpart
and I'll help you configure it manually, correctly (if its not already correct).