EasyBCD Fedora 15 not working

tbrooke

New Member
#1
I have been using easyBCD with Windows 7 on my main drive and Fedora on an SSD it worked fine with Fedora 12. I put in a new identical SSD with Fedora 15 and EasyBCD boots into grub when I select Fedora and says ERROR 15 if I press continue I get the menu that shows the kernel listing but I go back to the same error message . When I boot from an alternate using my system menu and choose the SSD it works fine and when I put in my old fedora 12 SSD it is fine.

Any suggestions? Must be something in Fedora ( I am not sure if they updated grub)

My setup is:

There are a total of 2 entries listed in the bootloader.

Default: Microsoft Windows 7
Timeout: 10 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Microsoft Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Fedora
BCD ID: {53897504-882c-11e0-878d-00247e693b07}
Device: boot
Bootloader Path: \NST\AutoNeoGrub1.mbr
 

mqudsi

Mostly Harmless
Staff member
#2
I don't understand the scenario you outlined in your first paragraph. Can you please rephrase?

Thanks.
 

Terry60

Knows where his towel is.
Staff member
#3
Are you saying that you just switched SSDs and selected the same Linux entry from the boot menu ?
If so, bear in mind that the location of the OS in the BCD is described by a UID which is partly comprised of the unique device serial number. You can't change the device and expect it to be found (error 15 means "can't find it").
You'll need to delete the entry for the old linux and add it again for the new one so that the correct UID gets generated.
 

tbrooke

New Member
#4
Fedora 15

I tried deleting and reinstalling everything and no luck. One thing I did was to try editing the easybcd menu and in my fedora section the first entry was hdd0,0 I changed this to hdd1,0 hit boot and it worked - However it doesn't save the change

If I could just edit and save that I would be OK
 

Terry60

Knows where his towel is.
Staff member
#5
"reinstalling" ???
just use "edit boot menu" to remove the Linux entry, then "add new entry" to add Linux with the new SSD connected.
 

tbrooke

New Member
#6
that is the problem

I have gone in and recreated the entry several times and if I check the box for grub not on disk it goes to error 15 file not found or if I leave the box unchecked it hangs I have tried every partition on the menu and I believe I have covered every other option on the menus

I can boot the SSD by going to my alternate boot menu on the setup menu in my laptop

or I can edit the fedora menu entry I created with easyBCD to change the first line from HDD0,0 to HDD1,0