EasyBCD helped, but not totally

#1
I installed Windows 7 four days ago in addition to an already existing Windows XP installation.
After trying hibernation on my windows 7 system, I could not reboot any longer for 'ntldr is missing'. Recovery within Windows 7 repair options failed, so I used EasyBCD in order to be able to boot again.
Windows 7 is now able to boot but not the older and very important Windows XP installation. Windows 7 is installed on partion C (harddisk 1), while Windows XP is installed on drive D (harddisk 2). So I added within EasyBCD the additional windows installation (first manually, then with version 2.0 by auto configuration of boot.ini). EasyBCD created the following boot.ini (on drive C:smile::

[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows XP on D:\" /fastdetect

There is visibly a wrong information within boot.ini for the Windows XP installation, it should be rdisk 0 as is shown by the old boot.ini:

;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Erwin Arbeit" /NOEXECUTE=OPTIN /FASTDETECT

I tried to modify the boot.ini file (created by EasyBCD) on drive C but even if I removed the 'only read' attribute, Windows 7 did not allow me to make the necessary modification ('no writing allowed'), in spite of my role as an administrator.

What can I do in order to make the necessary modifications?
Where should ntldr and ntdetect and boot.ini be located? on drive C or drive D?

Would be grateful for advice

Erwin
 

Terry60

Knows where his towel is.
Staff member
#2
Hi Erwin, welcome to NST.
boot.ini gets its information about disk numbers from the BIOS.
When you boot with the XP disk first in the BIOS, it uses its own copy of boot.ini with rdisk correctly set to (0) because rdisk(0) means "first in the BIOS i.e. the booted disk".
When you boot XP via W7's BCD, the copy of boot.ini in the W7 partition root must point to XP on the other HDD hence the rdisk(1), because now W7 is the booted disk (rdisk(0))
When you used the auto-configurator in 2.0, it created the correct boot.ini for you and it also told you to copy NTLDR and ntdetect.com across to the "system" partition.
Please read the sticky thread point 3 about locating your "system" partition and make sure that all the necessary files are there.
 

Terry60

Knows where his towel is.
Staff member
#4
No problem. Post again if you have any future problems and can't find the solution in the wiki or the threads.