easyBCD,hibenate error, win7 sp1, truecrypt

aoz

New Member
#1
have a drive, tablet pc toshiba
win7 32 bit, installed SP1.
it seems that now hibernate does not work; i select HIBERNATE when turning off, it goes theoruh the motions, but then on restart, it asks to "start windows normally", or SAFE mode, etc, as it does not seem that hibernate worked.

I have TRUECRYPT installed, encrypted the whole system drive, so i can't just boot with a vista DVD (don't even have a vista dvd or win 7 DVD courtsey of the computer manufacturers...)

If I do a BCDedit, I have TWO entries for "resume from hibernate".

I ahve tried to delete both, with the "bcdedit delete xxxxxxxx inherit; sometimes it was successful for one of the keys, and other times not, (that one had file path as c:smile:, but the second key gives me error, "error occurred while attempting to delete the specified data element.
Element not found."

THAT one has "unknown" as a path or location

HOW can I use easyBCD to fix this, clear out the two "resumefrom hibernate" entries, and see if I can get hibernate to work again?

AGAIN, drive uses a truecrypt bootloader, and I don't knwo how to bypass that, so any operation woudl have to be done once windows is up and running

any assistance appreciated.

nick
 

mqudsi

Mostly Harmless
Staff member
#2
Delete the existing entry in EasyBCD and replace it with a new one.
 

aoz

New Member
#3
thanks for reply.

but, that's what I don't understand, and don't want to crash my system.

do I just
1. install easyBCD
2. run it?

where do I see what is currently in the BCD data section, etc, in order to determine WHAT to delete?
thanks
NIck
 

aoz

New Member
#5
sorry, i must be dense
i downloaded, and ran it

in VIEW SETTINGS, it only shows me

"there are a total of two entries listed in bootloader"

windoes 7

windows Vista (I don't use this, system used to be vista; the win 7 upgrade left this in place)

I don't see anything about "resumeon Hibernate", etc

I don't see how to get to those listings that are shown in "bcdedit /enum all


thanks
nick
 

Terry60

Knows where his towel is.
Staff member
#6
You delete entries with "Edit boot Menu"
 

aoz

New Member
#7
thanks for reply.
tried that

all i see are two lines, each an entry;
one is windows 7
one is windows vista (which I don't even use)
there are NO other entries.

when I do bcdedit /enum, there are MULTIOPLE other entries, including the "on resume from hibernate", etc.

there are no other such listings in easyBCD when I select "EDIT"

????
i must be dense....

any assistance appreciated
 

JustinW

Super Moderator
Staff member
#8
EasyBCD gives you a basic view of your BCD settings. I wouldn't delete your existing entry right away, just add a new one. You can do that by clicking Add New Entry. If the new entry works, delete the old one. If it continues to not work, try decrypting the disk and entering hibernation. Theres been issues with hibernation not working on fully encrypted disks using TrueCrypt in the past if you do some Googling around. In that case, partition your hard drive so that you have a dedicated partition for your data or consider using an encrypted file container.
 

aoz

New Member
#9
thanks for reply.

1. re: encryption, etc -
4 machines, all encrypted, no problem with hibernation; just this tablet, started after Win7 SP1 installation.

I ahve found, in the registry, HKLM\BCD0000000\objects\and the value of TWO of the listings in the BCDedit, relating to the hiberfile location.

Can these be deleted manually?
or will that screw up the system?
I would have set the powercfg -h off

thanks
NIck
 

mqudsi

Mostly Harmless
Staff member
#10
We gave you the solution. Use it.
 

aoz

New Member
#11
thanks for reply

sorry, but none of solutions worked, .
NONE of these solutions changed the bcd info that I saw on display.

any editing with easyBCD, or others, did not alter what I saw for the "resume from hibernation" entries.

I then reverted back to a pre-SP1 image I had of Win7 backup.
Hibernate then DID work !
reinstalled SP1 - hibernate did NOT work.

BCDedit showed same values.

removed SP1 again- Hibernate DID work.

so nothing that the BCDedit (or easyBCD) did , aided the situation, turns out to be SP1.
searching on internet shows similar issues with others who are using hiberhate.

anyway, thanks for efforts