EasyBCD Install problem, fail to start

#1
Hi, really nice idea with the EasyBCD 1.7.1 but...
I've just tried your steps to install XP after Vista (I'll add a LINUX later) but I get an error on BCD startup "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem".
Needless to say, reinstalling/rebooting (several times) doesn't help, can you ? I'd really like to be able to re-boot into Vista.
Sequence of events, followed the doc...
PC shipped with Vista, all runs fine but I need to have an XP and LINUX OS capability.
Shrunk Vista partition and created a new NTFS partition for XP at the end of the drive using GPARTED.
Booted into Vista (some disk checking performed by the OS but all is OK) and Vista runs fine.
Installed XP Pro 32 to the new partition by booting from the XP CD, XP sets up, runs OK.
Installed the .NET framework (used dotnetfx.exe (22,960KB))(after having to download the windows installer KB893803-v2-x86).
Installed EasyBCD 1.7.1 (after having to download MSVCR71.dll into the Windows\System32 directory).
But I'm unable to run EasyBCD as each time I get the error dialogue listed above, "This application has failed to start....".
I need to get back to Vista where lots of my apps live.....
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Keithy, welcome to NeoSmart Technologies.

Sounds like a corrupted configuration file.
1) Go to \Documents and Settings\USERNAME\Local Settings\Application Data\
2) Delete the "NeoSmart_Technologies" folder
 
#3
Umm, no... that didn't improve the install problem...
I've uninstalled, deleted all folders with NeoSmart and even whizzed through the registry (scary) deleting NeoSmart entries. Still no joy when I try the install (same error message).
As I now hove two logical disks for my windows system (C: & D:smile:(Vista & XP), your install places the files on the current (XP) Program files location(D:smile: with no chance to install to the normal C: location, I tried copying the installed files from D:tongueout:rogr Files\ to C:tongueout:rogr Files with no change....
I really would like to use Vista again..
 

mqudsi

Mostly Harmless
Staff member
#4
Can you please post the rest of the application start failure error?
 
#5
Hi CG, the text above is it. That's all I get when I try to run the app, a dialogue box with "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem" in and an "OK" button...
Is there a quick/dirty way to boot into Vista while we figure out why EasyBCD won't run?
 
#7
Aaargh... I've a cheapskate recover DVD, I'll be downloading the .ISO from your posted link (when I'm on a faster connection)..
I'd like to be able to use EasyBCD, why won't it install/run?
Are there more diags I can get so you could fix the install?
When I've (hopefully) managed to get Vista back perhaps I could install using the Vista OS and try a LINUX?
 

mqudsi

Mostly Harmless
Staff member
#8
Yep, that's certainly possible.

I believe after you reset your Vista bootloader like we show in the guide it shouldn't be a problem to run EasyBCD in XP or Vista - good luck, and let us know how it goes.
 
#9
Phew, fortunately the .ISO Vista did all the work... Step 2 was good.
Now EasyBCD will install & runs (in Vista), still no idea why XP wasn't able but perhaps SP2 was required?
I've added the XP manually into EasyBCD and it's just booted in. Neat... and a big sigh..
Now I'll be looking to the LINUX install....
Are there instructions that detail the best way to get a LINUX (probably Fedora) into a PC with C:VISTA & D:XP??
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#10
I bet your XP failed not because of SP2 but because it requires .NET 2.0

Microsoft .NET 2.0+ Framework. (download here)
Taken from:

System Requirements - NeoSmart Technologies Wiki

.NET 2.0 is not installed by default and it came out later than SP2 for XP. So unless you installed it manually you dont have the basic requirements for EasyBCD.
 
#11
Hi Makiavelli.. Nope, I actually installed the .NET stuff (and the flipping MS Installer...)
I've booted back to XP & fitted SP2 and all the MS updates & BCD installs without a whimper..
V.Strange.
LINUX here I come (if I GPart the drive properly).
Cheers