EasyBCD menu not appearing when using a cold boot

#1
Installed EasyBCD 2.3 on a new build some time ago. Created a boot menu that allowed the selection between Window 10 (32 bit on a SSD) & Windows 10 (64 bit on a HHD). Everything worked fine until recently, but now the boot menu does not appear after a cold boot. When the computer is shutdown completely and then restarted, no boot menu appears, and the drive that was used the last time the computer was running (SSD or HD) will boot. If the computer already has either version of Windows 10 running, however, and then restarted without shutting the computer completely down (power off), the boot menu will appear and the default drive will start as normal if I do not make a change after the boot menu appears on screen. I am not certain what would cause this problem of no boot menu appearing only after a complete power off shutdown. I did uninstall and reinstall EasyBCD, but that did not solve the problem. Also Fastboot is not enabled on this computer.
 

mqudsi

Mostly Harmless
Staff member
#2
It sounds like you might be booting from a different drive (and hence, BCD) in the BIOS?
 
#3
Installed EasyBCD 2.3 on a new build some time ago. Created a boot menu that allowed the selection between Window 10 (32 bit on a SSD) & Windows 10 (64 bit on a HHD). Everything worked fine until recently, but now the boot menu does not appear after a cold boot. When the computer is shutdown completely and then restarted, no boot menu appears, and the drive that was used the last time the computer was running (SSD or HD) will boot. If the computer already has either version of Windows 10 running, however, and then restarted without shutting the computer completely down (power off), the boot menu will appear and the default drive will start as normal if I do not make a change after the boot menu appears on screen. I am not certain what would cause this problem of no boot menu appearing only after a complete power off shutdown. I did uninstall and reinstall EasyBCD, but that did not solve the problem. Also Fastboot is not enabled on this computer.
Stumbled across the answer to my question. Fastboot in the bios was never enabled, but somehow the "Turn on fast startup" was enabled under the shutdown portion of the system settings. In my version of Windows (Win 10 Pro), I was able to change this setting by going to Control Panel/Power Options/Choose what the power buttons do. Now the EasyBCD boot menu appears whenever the computer is booted.
 

Terry60

Knows where his towel is.
Staff member
#4
Sorry I didn't reply now.
I was going to point you to
https://neosmart.net/forums/showthread.php?t=12890
which seemed aposite until I read your last sentence, at which point I skipped to the next problem in line.
Sorry again if you wasted a few days finding the answer.