EasyBCD not showing hidden files on Windows 7 only? Possible Bug?

#1
Made this thread just in case this is a bug so the devs can be aware of it.

I accidentally reset my BCD on my main computer and was left with no menu entries to boot into Windows 10, so I took out my hard drive connected it to an older PC running Win7 Home Premium Service Pack 1(64bit) so I could edit the BCD using EasyBCD.

I opened explorer and changed the options to show hidden operating system files like is documented here Editing a BCD on a different disk
I then verified I could see hidden files in explorer, everything was working I could see the hidden \boot folder as well as hidden files like \boot\bcd and other hidden files unrelated to bcd.
I opened up EasyBCD and selected File -> Select BCD Store, then using the file picker I browsed to the correct drive with \boot\bcd on it, but I could not see any hidden folders or files in the file picker. I doubled checked explorer.exe was still showing hidden files then rebooted.....still EasyBCD is not showing hidden folders/files.
Within the 'select bcd store' file picker I manually navigated to \boot\ but the bcd file did not show up in the file picker, I manually typed out \boot\bcd in the nav bar but that did not work.

I thought maybe this was a bug or user error but then I checked on a Windows 10 PC that EasyBCD does show hidden files in the file picker, so the issue is only occurring on Windows 7 or maybe something is broken on that specific Windows 7 install(but what?)
 

mqudsi

Mostly Harmless
Staff member
#2
There are two different options that would need to be enabled - hidden files and system files. Did you check both?

EasyBCD doesn't have any say over what shows up in the open file dialog (which is a standard Windows component) apart from what file types (extensions) are shown.