EASYBCD problem after reinstalling Vista

#1
Hi !

Excuse me for my approximate English.
I run a Vista-Ubuntu dual boot and it worked till now perfectly with EASYBCD 1.7.2.
Last days, I reinstalled Vista and EASYBCD after so that I could find back my dual boot.

There are my 2 entries (Vista and Ubuntu) when I boot my PC. My problem is that when I choose Ubuntu, I've got 2 lines of "boot generic" (instead of 1 before) and so as for "boot recovery". After clicking on "boot generic", I have a message like this : "(hdo,4)... Warning : unrecognized partition table for drive 80. Please rebuild it using Microsoft compatible FDISK (err=26)"... and a little farther : "init boot/intrd.img... 2.6.24-21...". Anyway, Ubuntu starts after this quick view.

I checked my EASYBCD settings, and I found that Neogrub was installed. I never used this tab...
For information : I checked "Grub isn't installed in bootsector" because Ubuntu Grub isn't installed in Vista MBR.

Thanks in advance for your help.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
When you installed Ubuntu did you install GRUB to the MBR? If so it was most likely lost when you reinstalled Vista. Try to reinstall GRUB to the Ubuntu partition.

How to install Grub from a live Ubuntu cd. - Ubuntu Forums

Use that. Then remove the Linux entry and add it again with GRUB not installed to the MBR. See if that helps.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#4
okay so did you try to remove the entry and add it again?
 
#5
Yes I did. But as soon as I check "Grub isn't installed in the bootsector", Neogrub will automatically installed.
This is my "View Settings" in EASYBCD :

 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#6
Yes if you check that box NeoGRUB will auto install. IT is jsut used as a gateway to GRUB. REmove the entry. Save your settings. Close down EasyBCD. Then restart EasyBCD. Add a Entry again. Try it first without the box checked.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#8
I cant guarantee that you will be able to boot into Linux. But you can still get into Vista and try to fix the issue. With GRUb and adding the entry i have seen that a reinstall of Vista and trying to figure out how to get the dual boot workign again is tricky. At least for me it has. Sometimes i have had to use the GRUB not installed to the MBR method while others i have not had to use it.

It is just trial and error to see which way will work.
 
#9
Thank you Makaveli,

It works ! But I still have the 2 lines of "boot generic" (instead of 1 before) and "boot recovery" (instead of 1 before) when I choose Ubuntu. But maybe this is not your field anymore !
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#10
I would think that would be part of the GRUB. Boot into Ubuntu and try to edit the GRUB menu to show what you want.

I am not all the familiar with GRUB and am by far a expert on it. But i think that should work?!?

In any case i am glad that it is working now. Sorry that it took so many attempts to get it working. But if experience has tought me one thing. Trial and error is the best way to get things done. :wink:
 

mqudsi

Mostly Harmless
Staff member
#11
You'd need to modify /boot/grub/menu.lst in Ubuntu to get rid of those lines, but I advise that you don't since they could come in handy (they're the equivalent of Safe Mode in Windows)