EasyBCD unable to repair Vista BCD

#1
I was experimenting with installing OpenSuSE on an existing Vista PC. After Linux install, I accidentally installed the GRUB bootloader on the MBR thus destroying the Vista MBR information. But GRUB still detected Vista and I could dual boot without a problem.

When I tried to take a full backup of Vista it failed. After researching the error, I found that if Vista's MBR is not active, the Volume Shadow Service fails to take a complete backup.

I downloaded EasyBCD 1.7.2 since I knew it can rebuild the Vista MBR and I can add Linux later. When I run EasyBCD, it just tell me that MBR/BCD information is incorrect and offers to correct it. There are only two choice Yes or No. If I press No, the program exits. If I press Yes, the program further complains that it cannot identify the boot disk and offers a list of all disks/partitions. I select C: drive. The program then complains that it cannot identify the Vista disk. I select C: drive again and the program exits with an error that it cannot repair.

How can I restore the BCD data? Should I go to the manual method of BCD restore as pointed out under the Nuclear Holocaust section of the documentation?

Thanks...
 
#3
I am already following the Wiki article but it is incorrect. There is no file by the name of bootsect.exe.

x:\boot\bootsect.exe /nt60 all /force

I searched in all drives but there is no file bootsect.exe. The second problem is that no matter what I do, I always get this message:

The Volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted.

Using the DVD, Startup Repair tells me that the volume is corrupted. However, both Vista and Linux are running fine.

Thanks...
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#4
HYello,.

That is saying that your system is corrupt. Not that our documentation is incorrect.

If it can not recognize the file system you have lost the partition tables. At which point Vista will be unable to be recovered and must be reinstalled.

Cheers,
Mak
 

Terry60

Knows where his towel is.
Staff member
#5
Did you use Linux or Vista to resize your partitions before you installed SuSE ?
If you had a preinstalled Vista, it would have used the latest standards for partition alignment, and would have maintained it, if Vista did the shrinking.
If you let linux do the partition sizing, it would probably have reverted to the old alignment standards (Vista is ahead of the field in this respect), which would explain why Vista boot thinks that everything is screwed, but linux doesn't.
You can install Vista into partitions which conform to the old standards (it's backwards compatible), like I have on my system by pre formatting the HDD with Paragon Partition Manager, but once it's been installed by letting it do the formatting, then playing about with older partitioning software will damage it. (they're not forward compatible)

Look at this thread
http://neosmart.net/forums/showthread.php?p=21683#post21683
and see if the Dell workaround quoted is any use to you.
 
Last edited:
#6
The documentation is incorrect in that the bootsect.exe program is obsolete and has been replaced by bootrec.exe /fixboot.

x:\boot\bootsect.exe /nt60 all /force
is obsolete

Use bootrec.exe /fixboot instead. I found this information somewhere on the NeoSmart website. I hope someone takes time to update the Wiki article.

I used Vista to partition the disk. I found the problem to be the following.

I had created a 40GB partition on the C: drive to install Linux. After installation, Linux had divided the 40GB partition into two partitions, one of 79MB and the other 39.93GB. The 79MB partition had been marked active instead of the partition containing C: drive. I changed the active partition to C: drive and booted into Vista. EasyBCD started working correctly. The message about unrecognized file system disappeared and Vista backup started working fine.

But now I cannot boot into Linux. I tried reinstalling Linux with same results. It creates a smaller 79 MB partition and marks that partition as active causing Vista/EasyBCD to malfunction. If I change the active partition back to Vista and use EasyBCD to add Linux, I just get a GRUB prompt. I cannot boot into Linux.

I do not see any option in OpenSuSE 11 to install GRUB to bootsector of the partition instead of MBR. I will experiment with more options and post the results here if successful.

If someone already know how to do it, I will really appreciate it as it will save me a lot of time.

Thanks...
 

mqudsi

Mostly Harmless
Staff member
#7
I don't believe the documentation actually states that bootsect is obsolete, in fact, we clarify the relationship between bootsect and bootrec quite plainly here:

Bootsect.exe Modifies the Bootsector Not the MBR!! The NeoSmart Files

As for your dual-boot problem: Try using the "GRUB is not installed to the bootsector" checkbox when adding an entry - does that solve your problem?
 

JTech

New Member
#8
Similar issue

Hi, I successful did a fedora dual boot, but after switching to suse and using suse to reformat my linux partitions (nothing was done to the vista partition) I get the grub bootloader.

I can still get into windows fine, but easyBCD does not work. got the same errors the first guy got. when I get to the vista bootloader, it still lists the fedora 9 entry, and still exists somewhere. I just want to get easyBCD and the vista bootloader back in control. Even if linux dies in the process, I can reinstall suse, fedora, or something else later. I do ont have a install dvd for vista, just system recovery dvds from compaq. How do I change the active partiton on my drive?

Any thoughts or advice is appreciated.

-JTech

Addendum:

I use suse 10.3
 
Last edited:
#10
Alternatives?

can I change the active partition with a normal live linux cd? I am on dial-up, so It may take quite a while to get the other software downloaded. I am currently downloading the .iso file.

Thanks!

-JTech
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#11
Hello,

Does the LiveCD of Linux you have come with the GParted utility? If so then yes you can. Not all LiveCD's haev this utility with them so you should check if it does. If so you are good to go. but if not then you will need to download it.

Cheers,
Mak
 
#12
How would I know if the live cd has the tool? Is there a list of live cd's with the tool somewhere?
Has anyone heard of partition Logic, a freeware bootable app?

Thanks!

-JTech
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#13
Hello,

Load up the CD and check on there. That will be the easiest way to check.

Cheers,
Mak
 
#15
Solved!

Good news!

I have a functional dual boot with the vista bootloader on top.
The solution: a super GRUB disk. It allowed me to change the active partiton, and was a 4MB download.
So now easyBCD and the vista bootloader work. Thanks for your help, I know know a little more about dual booting.

Keep up the good work!

-JTech
 

mqudsi

Mostly Harmless
Staff member
#16
Hey JTech, glad you got it working :smile:
Congrats.