EasyBCD V2.0 beta build 100 does not start

#1
June 24, 2010
Hello Computer Guru:
I'm Paolo from Italy. I appreciate your hard work on EASYBCD very much, I use and evaluate the V2.0
beta since its first builds.
Now I send this post in order to report a problem that had arose since the beta builds released after
March, 2010.
I use some test machines with ABIT AN-7 or BIOSTAR K8-M800-M7A, and in every machine there are both
two 500 GB IDE Hard Disks and two SATA 1TB Hard Disks. The processor is an AMD (Barton) 2500+ in the
AN-7 machine, an AMD Athlon 64 3700+ (running at 2.4 GHz) in the Biostar machine. RAM is 2 GB in both
machines. But the machine constitution or components are uninfluent, since the same problem appears
in every machine.
In those computers I have the following OS'es:
- MS-DOS 6.22, Windows XP SP3, Vista SP2 and Windows 7 in the first IDE disk (four separate
partitions);
- Windows XP SP3, Vista SP2 and Windows 7 in the first SATA disk (in separate pertitions).
In my machines, the boot is handled by V-Comm's System Commander 9.04 (an old boot manager that
overcomes Vista and Windows 7 boot system) and everyting is working good.
Until the EasyBCD 2.0 beta releases of March 2010, the program worked fine, it started correctly if
launched from Vista or Windows 7 resident in the first IDE disk and - obviously- showed the message
"BCD not found" when launched from Vista or Windows 7 resident in the first SATA disk (this is due to
the particular System Commander's hiding method).
But from the EASYBCD releases that came after March 2010 (I'm now using the beta build 100) and
INDIPENDENTLY FROM THE BOOTING PARTITION (i.e. from the first IDE or from the first SATA disk),
whenever EasyBCD is launched, neither any message nor the "initial" BCD screens appear (please note
that in Task Manager's "Processes" windows both "bootgrabber.exe" and "EasyBCD.exe" regularly appear
as "running").
This happens in every of my machines and in Vista or Windows 7.
I downloaded from the forum the "EasyBCD 2.0 build 103 DEBUG" and I installed it, but the problem
still remains.
I also tried to replace the file "bootgrabber.exe" with the latest version (from the forum), but with
no results.
Finally I stopped the "bootgrabber.exe" process from the Task Manager/Processes window and, just afer
having stopped that process... Wow, the "EASYBCD screen appeared immediately! And this happens both
in Vista or Windows 7, independently from the boot partition.
So I guess the problem is related with the "bootgrabber.exe" file, but I am not sure.
As I know you are currently working on the EasyBCD 2.0 "Final Build" I send you this report.
I hope that if the problem is due to a bug, it can be corrected before the "Final" release.
I also hope that this can be of any help for your work.
I apologize for the trouble, again many congratulations and best regards,
Paolo
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Paolo,

Thanks for your bug report. Can you please post a screenshot of Disk Management?

Thanks.
 
#3
Maybe this is a solution!

June 26, 2010
Hello again Computer Guru:
Thank you very much for your early reply, attached you'll find the file "Disk Management
screenshots.zip" that will show you the disk configuration in 3 of my machines (No. 01-ABIT, No. 02-BIOSTAR 1, No. 04-BIOSTAR 2). For each machine you will find the screenshots taken with the OS resident in an IDE or in a SATA disk. I always used Windows 7 as OS (I could have used Vista but the situations would have been the same, Win 7 is much faster to boot). Sorry, the OS language is Italian, but I hope this is not a problem.
I apologize for the delay in answering, but yesterday I decided to proceed in further tests of the various EasyBCD beta builds for the whole day and now I am able to talk about the results.
a) The problem I reported in my post (EasyBCD 2.0 beta doesn't start) arises after the 2.0.0.81 build. Build 82 (in the "About" window it appears "Version 2.0.0.81" however) is the latest that works fine and starting with the Build 86 (I have no EASYBCD version between the build 82 and the build 86) the program shows the above mentioned problem.
b) Probably it is not true that EasyBCD "does not start". It starts really, but its "initial" window does not appear (or, better, it appears only after a long time - about twenty minutes in some cases!).
I already reported that the only way to have EasyBCD starting immediately is to kill the "bootgrabber.exe" process in the "processes" window of the Task Manager.
c) I am now sure that the problem is related to the latest "bootgrabber.exe" file versions.
If you replace in the "bin" subfolder the latest "bootgrabber.exe" version (06-09-2010 h. 16.15, 103 Kb) with the corresponding file that belongs to the EasyBCD beta build 82 (02-15-2010 h. 16.15, 96 Kb), the problem disappears and EasyBCD build 100 (or build 103) starts immediately and works very fine.
And this is the solution I applied (for now) to every instance of EasyBCD V2.0 beta I have.
I hope this can be of some help. If you need I proceed to further tests, please let me know, I'll be glad to offer my (humble and very small) contribution to the developement of such a wonderful software.
Best regards,
Paolo
 

Attachments

mqudsi

Mostly Harmless
Staff member
#4
Question:

If you run "bootgrabber.exe /tlist" from the command line, what output does it show before it hangs?

Addendum:

Oh, and thanks for your meticulous ground work on this one :smile:
 
Last edited:
#5
bootgrabber.exe /Tlist results

June 26, 2010
Hi Computer Guru:
In the attached files "Tlist results.zip" you'll find the screenshots of the bootgrabber.exe /tlist
from the command line. I've enclosed the screnshoots of only one machine (ABIT AN-7) in different
situations (Win 7 in IDE or SATA partition, Bootgrabber.exe of the latest version or of the version
that came with EasyBCD beta build 82). Hope this can be of help.
From the results I argue that the latest bootgrabber.exe version slows the appearing of the EasyBCD
screen because it is necessary to access all the disks first (while the older bootgrabber.exe version
simply hangs).
Anyway, with the older bootgrabber.exe version, EasyBCD starts almost instantly.
Have a nice weekend, regards
Paolo
 

Attachments

mqudsi

Mostly Harmless
Staff member
#6
OK, I'm a bit lost.

1) The old version of BootGrabber uses "/list" and not "/tlist" - I forgot to tell you
2) That doesn't really matter because if (the newest) BootGrabber.exe actually prints all that, there should be no problem.

How long does it take for the latest BootGrabber to print all this info?
 
#7
EasyBCD timings

June 30, 2010
Hello again Computer Guru:
Sorry, I didn't know anything about the "\list" option of the old bootgrabber versions and I used "/tlist" mistakenly.
I repeated the test with the right command and attached you'll find the file "Old bootgrabber list results.zip" from one of my machines (ABIT No. 01). The results are almost identical in all the other machines.
About the timings, please take a look at the attached file "list-tlist printing times.txt".
Please notice I reported the printing times only under Windows 7 (both from the SATA and the IDE disks), under Windows Vista printing times are higher, as that OS is slower by itself.
Again, the results are almost identical in all my other machines anyway.
But, nothwithstanding the "printing times" are not so different between the older and the latest bootgrabber versions, the EasyBCD window ("error" or "regular") appears almost instantly whenever the old bootgrabber version is used.
In my opinion, this is because the later bootgrabber versions force the program to stop until bootgrabber has finished to seek and identify all the computer drives, maybe I'm wrong.
Incidentally, why EasyBCD starts with the "regular" window when the OS resides in the first IDE disk and with the "error" window when the OS resides in the SATA disk?
I guess this is due to the boot manager I'm using (V-Comm's - Avanquest's - System Commander V 9.04, that makes use of a particular partition hiding mode that overcomes Vista and Windows 7 booting system).
What is your opinion on the specific matter? Perhaps is it better to allow EasyBCD to load a BCD registry whenever I choose to boot one of the SATA-resident OS'es? Please let me know.
Incidentally again: I posted (to another thread) that, if you wish, I could provide to the EasyBCD language translation (into Italian).
Hope tyhis can be of help.
Thanks again for everything, best regards!
Paolo
 

Attachments

mqudsi

Mostly Harmless
Staff member
#8
Oh, ok! In that case, I think all is well.

I was deluding under the impression that EasyBCD itself didn't *ever* start (i.e. that bootgrabber.exe would get stuck forever), but I now see that after a minute and a half, bootgrabber terminates and EasyBCD starts.

You're right - old versions of EasyBCD did NOT wait for BootGrabber.exe at startup - but if you want to the "Linux" section, EasyBCD would end up hanging for the same 2 minutes.

The error message you get is indeed caused by System Commander's hiding of the boot partition.

I will let you know when I'm ready to begin work on translated versions of EasyBCD and really appreciate your offer.

New EasyBCD issue as a result of this thread (To be fixed in a post-2.0 update):
* EBCD-372: EasyBCD blocks until BootGrabber finishes execution
* EBCD-373: BootGrabber.exe should skip floppy disks
 
#9
All's well that ends well!

June 30, 2010
Hi Computer Guru:
Many thanks for your early reply.
Oh... I am sorry for having given you the impression that EasyBCD itself doesn't start, I should have been more precise, I apologize.
Anyway all's well that ends well and I thank you very much again.
About the fact that old versions of EasyBCD did not wait for bootgrabber.exe at startup and about the "error" message I receive whenever the OS is in a SATA disk, glad to hear that what I supposed is right.
OK on the translated versions of EasyBCD, I'll wait for your request (you know my email address).
Finally, if you need I run any further test of EasyBCD on my several machines (for any purpose), please feel free to contact me, it would be nice for me to be of some help.
Thanks again, best regards!
Paolo
 

mqudsi

Mostly Harmless
Staff member
#10
Thanks for all your help, Paolo.